summaryrefslogtreecommitdiff
path: root/libmatemixer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libmatemixer/Makefile.am')
-rw-r--r--libmatemixer/Makefile.am25
1 files changed, 3 insertions, 22 deletions
diff --git a/libmatemixer/Makefile.am b/libmatemixer/Makefile.am
index a986a98..a269397 100644
--- a/libmatemixer/Makefile.am
+++ b/libmatemixer/Makefile.am
@@ -7,10 +7,6 @@ AM_CPPFLAGS = \
-DG_LOG_DOMAIN=\"libmatemixer\" \
-DLIBMATEMIXER_BACKEND_DIR=\"$(libdir)/libmatemixer\"
-BUILT_SOURCES = \
- matemixer-enum-types.c \
- matemixer-enum-types.h
-
libmatemixer_includedir = $(includedir)/libmatemixer
libmatemixer_include_HEADERS = \
@@ -32,8 +28,9 @@ libmatemixer_la_SOURCES = \
matemixer-device.c \
matemixer-device-port.c \
matemixer-device-profile.c \
- matemixer-track.c \
- $(BUILD_SOURCES)
+ matemixer-enum-types.c \
+ matemixer-enum-types.h \
+ matemixer-track.c
libmatemixer_la_LIBADD = $(GLIB_LIBS)
@@ -41,20 +38,4 @@ libmatemixer_la_LDFLAGS = \
-version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
-export-dynamic
-libmatemixer_ENUM_TYPES = matemixer-enums.h
-
-matemixer-enum-types.h: $(libmatemixer_ENUM_TYPES)
- $(AM_V_GEN) (cd $(srcdir) && $(GLIB_MKENUMS) --template matemixer-enum-types.h.template \
- $(libmatemixer_ENUM_TYPES) ) > matemixer-enum-types.h.tmp \
- && mv matemixer-enum-types.h.tmp matemixer-enum-types.h \
- || rm -f matemixer-enum-type.h.tmp
-
-matemixer-enum-types.c: $(libmatemixer_ENUM_TYPES)
- $(AM_V_GEN) (cd $(srcdir) && $(GLIB_MKENUMS) --template matemixer-enum-types.c.template \
- $(libmatemixer_ENUM_TYPES) ) > matemixer-enum-types.c.tmp \
- && mv matemixer-enum-types.c.tmp matemixer-enum-types.c \
- || rm -f matemixer-enum-type.c.tmp
-
-CLEANFILES = $(BUILT_SOURCES)
-
-include $(top_srcdir)/git.mk