summaryrefslogtreecommitdiff
path: root/src/themes/meson.build
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2019-06-19 22:04:32 +0800
committerlukefromdc <[email protected]>2019-07-13 22:26:39 +0000
commitd86c29b0e518f765e7570573c76bc033fbd17f6d (patch)
treea4ac9135d5328c8955f4a60b70ee86a5ee22150c /src/themes/meson.build
parent9c6676b1efa27aa103b5eddb28f97488a63a5190 (diff)
downloadmarco-d86c29b0e518f765e7570573c76bc033fbd17f6d.tar.bz2
marco-d86c29b0e518f765e7570573c76bc033fbd17f6d.tar.xz
switch to use meson build system
Diffstat (limited to 'src/themes/meson.build')
-rw-r--r--src/themes/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/themes/meson.build b/src/themes/meson.build
new file mode 100644
index 00000000..e11da1f5
--- /dev/null
+++ b/src/themes/meson.build
@@ -0,0 +1,20 @@
+themes = [
+ 'ClearlooksRe',
+ 'eOS',
+ 'DustBlue',
+ 'WinMe',
+ 'Splint-Left',
+ 'Dopple',
+ 'Spidey-Left',
+ 'Splint',
+ 'Dopple-Left',
+ 'Spidey',
+]
+
+themedir = join_paths(datadir, 'themes')
+foreach theme: themes
+ install_subdir(theme,
+ install_dir : join_paths(themedir, theme, 'metacity-1'),
+ strip_directory : true
+ )
+endforeach