summaryrefslogtreecommitdiff
path: root/src/themes/meson.build
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2019-07-13 18:54:29 +0800
committerlukefromdc <[email protected]>2019-07-13 22:26:39 +0000
commit1960241cc70814439bfc9432dd94bd6057a60652 (patch)
tree9890aaa5d3471569577f9781465dbf3498784587 /src/themes/meson.build
parentd86c29b0e518f765e7570573c76bc033fbd17f6d (diff)
downloadmarco-1960241cc70814439bfc9432dd94bd6057a60652.tar.bz2
marco-1960241cc70814439bfc9432dd94bd6057a60652.tar.xz
meson: use install_data to replace install_dir
Diffstat (limited to 'src/themes/meson.build')
-rw-r--r--src/themes/meson.build30
1 files changed, 10 insertions, 20 deletions
diff --git a/src/themes/meson.build b/src/themes/meson.build
index e11da1f5..f9a4470d 100644
--- a/src/themes/meson.build
+++ b/src/themes/meson.build
@@ -1,20 +1,10 @@
-themes = [
- 'ClearlooksRe',
- 'eOS',
- 'DustBlue',
- 'WinMe',
- 'Splint-Left',
- 'Dopple',
- 'Spidey-Left',
- 'Splint',
- 'Dopple-Left',
- 'Spidey',
-]
-
-themedir = join_paths(datadir, 'themes')
-foreach theme: themes
- install_subdir(theme,
- install_dir : join_paths(themedir, theme, 'metacity-1'),
- strip_directory : true
- )
-endforeach
+subdir('ClearlooksRe')
+subdir('eOS')
+subdir('DustBlue')
+subdir('WinMe')
+subdir('Splint-Left')
+subdir('Dopple')
+subdir('Spidey-Left')
+subdir('Splint')
+subdir('Dopple-Left')
+subdir('Spidey')