summaryrefslogtreecommitdiff
path: root/accessx-status/data/Makefile.am
diff options
context:
space:
mode:
authorlukefromdc <[email protected]>2023-07-11 21:28:01 -0400
committerraveit65 <[email protected]>2023-07-17 02:47:28 +0200
commit08bb8398e0d218daaefdfe95c44940e370802508 (patch)
tree0c567b638dd31d831141a2ca4ef355a406883e08 /accessx-status/data/Makefile.am
parentf94afff3bd198dca2412a75053e122c55b4b48dd (diff)
downloadmate-applets-08bb8398e0d218daaefdfe95c44940e370802508.tar.bz2
mate-applets-08bb8398e0d218daaefdfe95c44940e370802508.tar.xz
Allow building all applets in or out of process
*Use --enable-in-process selector for in-process builds *Accessx-status: mark as incompatable with wayland *Accessx-status: Fix in-process runtime warning *Stickynote, Geyes: style fixes
Diffstat (limited to 'accessx-status/data/Makefile.am')
-rw-r--r--accessx-status/data/Makefile.am20
1 files changed, 15 insertions, 5 deletions
diff --git a/accessx-status/data/Makefile.am b/accessx-status/data/Makefile.am
index 58df0294..357ef0fd 100644
--- a/accessx-status/data/Makefile.am
+++ b/accessx-status/data/Makefile.am
@@ -1,26 +1,36 @@
NULL =
-appletdir = $(datadir)/mate-panel/applets
applet_in_files = org.mate.applets.AccessxStatusApplet.mate-panel-applet.desktop.in
+service_in_files = org.mate.panel.applet.AccessxStatusAppletFactory.service.in
+
+if ENABLE_IN_PROCESS
+APPLET_LOCATION = $(pkglibdir)/libmate-accessx-status-applet.so
+else !ENABLE_IN_PROCESS
+APPLET_LOCATION = $(libexecdir)/accessx-status-applet
+endif !ENABLE_IN_PROCESS
+
+appletdir = $(datadir)/mate-panel/applets
applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
$(applet_in_files): $(applet_in_files).in Makefile
$(AM_V_GEN)sed \
- -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
+ -e "s|\@APPLET_LOCATION\@|$(APPLET_LOCATION)|" \
+ -e "s|\@APPLET_IN_PROCESS\@|$(APPLET_IN_PROCESS)|" \
-e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
$< > $@
$(applet_DATA): $(applet_in_files) Makefile
$(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
+if !ENABLE_IN_PROCESS
servicedir = $(datadir)/dbus-1/services
-service_in_files = org.mate.panel.applet.AccessxStatusAppletFactory.service.in
service_DATA = $(service_in_files:.service.in=.service)
-org.mate.panel.applet.AccessxStatusAppletFactory.service: $(service_in_files)
+$(service_DATA): $(service_in_files) Makefile
$(AM_V_GEN)sed \
- -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
+ -e "s|\@APPLET_LOCATION\@|$(APPLET_LOCATION)|" \
$< > $@
+endif !ENABLE_IN_PROCESS
CLEANFILES = \
$(applet_DATA) \