summaryrefslogtreecommitdiff
path: root/battstat/sounds/Makefile.am
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2019-12-25 17:58:28 +0800
committerraveit65 <[email protected]>2020-01-09 11:40:14 +0100
commitb91dbe12e8f334e7fbaf9a36814d36d63c94dfd4 (patch)
tree699e3fa9a88533a37cc364c28b8afbfc0f360973 /battstat/sounds/Makefile.am
parent42022afd3340fc97b8c0c8866f2cd6b1355dee34 (diff)
downloadmate-applets-b91dbe12e8f334e7fbaf9a36814d36d63c94dfd4.tar.bz2
mate-applets-b91dbe12e8f334e7fbaf9a36814d36d63c94dfd4.tar.xz
migrate from intltools to gettext
Diffstat (limited to 'battstat/sounds/Makefile.am')
-rw-r--r--battstat/sounds/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/battstat/sounds/Makefile.am b/battstat/sounds/Makefile.am
index df677219..5b591d0c 100644
--- a/battstat/sounds/Makefile.am
+++ b/battstat/sounds/Makefile.am
@@ -1,9 +1,10 @@
soundlistdir = $(sysconfdir)/sound/events
-soundlist_in_files = mate-battstat_applet.soundlist.in
-soundlist_DATA = $(soundlist_in_files:.soundlist.in=.soundlist)
+soundlist_in_files = mate-battstat_applet.soundlist.desktop.in
+soundlist_DATA = $(soundlist_in_files:.soundlist.desktop.in=.soundlist)
-@INTLTOOL_SOUNDLIST_RULE@
+$(soundlist_DATA): $(soundlist_in_files) Makefile
+ $(AM_V_GEN) $(MSGFMT) --desktop --keyword=description --template $< -d $(top_srcdir)/po -o $@
EXTRA_DIST = $(soundlist_DATA) $(soundlist_in_files)