summaryrefslogtreecommitdiff
path: root/command/data/Makefile.am
diff options
context:
space:
mode:
authorlukefromdc <[email protected]>2023-06-19 01:46:33 -0400
committerraveit65 <[email protected]>2023-07-17 02:47:28 +0200
commit168de875415d503d2fc66d28f5e6f87b6871f693 (patch)
tree344cc3ed4f29a6726a2c882fd7aab0ca67f47e02 /command/data/Makefile.am
parent6363c16faf18cc5780bdcb9d53420a583a6482e7 (diff)
downloadmate-applets-168de875415d503d2fc66d28f5e6f87b6871f693.tar.bz2
mate-applets-168de875415d503d2fc66d28f5e6f87b6871f693.tar.xz
command: Port to in-process for wayland compatability
- fix runtime warnings on applet removal - disconnect signal on shutdown that otherwise throws warnings - Required moving a function so it would be defined in time
Diffstat (limited to 'command/data/Makefile.am')
-rw-r--r--command/data/Makefile.am14
1 files changed, 2 insertions, 12 deletions
diff --git a/command/data/Makefile.am b/command/data/Makefile.am
index b94e9523..b6c82434 100644
--- a/command/data/Makefile.am
+++ b/command/data/Makefile.am
@@ -1,4 +1,4 @@
-APPLET_LOCATION = $(libexecdir)/command-applet
+APPLET_LOCATION = $(libdir)/mate-applets/libcommand-applet.so
appletsdir = $(datadir)/mate-panel/applets
applets_in_files = org.mate.applets.CommandApplet.mate-panel-applet.desktop.in
@@ -6,20 +6,12 @@ applets_DATA = $(applets_in_files:.mate-panel-applet.desktop.in=.mate-panel-
$(applets_in_files): $(applets_in_files).in Makefile
$(AM_V_GEN)sed \
- -e "s|\@LOCATION\@|$(APPLET_LOCATION)|" \
+ -e "s|\@APPLET_LOCATION\@|$(APPLET_LOCATION)|" \
$< > $@
$(applets_DATA): $(applets_in_files) Makefile
$(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
-servicedir = $(datadir)/dbus-1/services
-service_in_files = org.mate.panel.applet.CommandAppletFactory.service.in
-service_DATA = $(service_in_files:.service.in=.service)
-
-org.mate.panel.applet.CommandAppletFactory.service: $(service_in_files)
- $(AM_V_GEN)sed \
- -e "s|\@LOCATION\@|$(APPLET_LOCATION)|" \
- $< > $@
command_gschema_in_files = org.mate.panel.applet.command.gschema.xml.in
gsettings_SCHEMAS = $(command_gschema_in_files:.xml.in=.xml)
@@ -27,7 +19,6 @@ gsettings_SCHEMAS = $(command_gschema_in_files:.xml.in=.xml)
EXTRA_DIST = \
$(applets_in_files).in \
- $(service_in_files) \
$(command_gschema_in_files) \
command-preferences.ui \
command-resources.gresource.xml
@@ -35,7 +26,6 @@ EXTRA_DIST = \
CLEANFILES = \
$(applets_DATA) \
$(applets_in_files) \
- $(service_DATA) \
$(gsettings_SCHEMAS) \
*.gschema.valid