summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrbuj <[email protected]>2020-02-12 23:24:27 +0100
committerraveit65 <[email protected]>2020-03-14 14:40:47 +0100
commit37a85e35448f8beed2654a4df07a303283a86aac (patch)
tree95a907f985968653300b8ba863a57fea7f99fdda /configure.ac
parentac0ebc185e14891ffeb98a94f35109603ee45078 (diff)
downloadmate-applets-37a85e35448f8beed2654a4df07a303283a86aac.tar.bz2
mate-applets-37a85e35448f8beed2654a4df07a303283a86aac.tar.xz
stickynotes: Use gresources for UI files
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 19 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 060c65d0..5839f41c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -228,11 +228,29 @@ AC_SUBST(LIBMATEWEATHER_LIBS)
AM_CONDITIONAL(BUILD_LIBMATEWEATHER_APPLETS, $build_libmateweather_applets)
dnl ***************************************************************************
-dnl *** GSettings ***
+dnl *** GSettings ***
dnl ***************************************************************************
GLIB_GSETTINGS
dnl ***************************************************************************
+dnl *** GLIB_COMPILE_RESOURCES ***
+dnl ***************************************************************************
+AC_ARG_VAR([GLIB_COMPILE_RESOURCES],[glib-compile-resources bin])
+AC_PATH_PROG([GLIB_COMPILE_RESOURCES],[glib-compile-resources],[])
+if test -z "$GLIB_COMPILE_RESOURCES"; then
+ AC_MSG_ERROR([glib-compile-resources not found])
+fi
+
+dnl ***************************************************************************
+dnl *** XMLLINT ***
+dnl ***************************************************************************
+AC_ARG_VAR([XMLLINT],[xmllint bin])
+AC_PATH_PROG([XMLLINT],[xmllint],[])
+if test -z "$XMLLINT"; then
+ AC_MSG_ERROR([xmllint not found])
+fi
+
+dnl ***************************************************************************
dnl *** Set up gettext ***
dnl ***************************************************************************