summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Hesse <[email protected]>2019-12-13 15:11:44 +0100
committerraveit65 <[email protected]>2020-01-10 16:53:23 +0100
commit9714c20d062af14e9b6cbf4cf3c9374acc6b9101 (patch)
tree5935e11e3078fae0bbbb8be2f92c59178ba365d8 /configure.ac
parentc614601d1ec06a0de963039d247c8d0f6d1db298 (diff)
downloadmate-applets-9714c20d062af14e9b6cbf4cf3c9374acc6b9101.tar.bz2
mate-applets-9714c20d062af14e9b6cbf4cf3c9374acc6b9101.tar.xz
make the dbus directory configurable
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1709f512..3c5e19a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -133,6 +133,17 @@ fi
AC_SUBST(LIBNOTIFY_CFLAGS)
AC_SUBST(LIBNOTIFY_LIBS)
+dnl -- Check for D-Bus -----------------------------------------
+AC_ARG_WITH(dbus-sys,
+ [AC_HELP_STRING([--with-dbus-sys=<dir>],
+ [where D-BUS system.d directory is])])
+if ! test -z "$with_dbus_sys" ; then
+ DBUS_SYS_DIR="$with_dbus_sys"
+else
+ DBUS_SYS_DIR='${sysconfdir}/dbus-1/system.d'
+fi
+AC_SUBST(DBUS_SYS_DIR)
+
dnl -- check for glib/gobject (required) --------------------------------------
PKG_CHECK_MODULES(CPUFREQ_SELECTOR, glib-2.0 >= $GLIB_REQUIRED gobject-2.0 >= $GLIB_REQUIRED)
AC_SUBST(CPUFREQ_SELECTOR_CFLAGS)