summaryrefslogtreecommitdiff
path: root/geyes/icons/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2020-08-01 12:52:49 +0200
committerraveit65 <[email protected]>2020-08-11 16:46:01 +0200
commit914262d420e78766ae11b85403aa2247d5054d46 (patch)
treee96a00081af65a1523ff0bbfbb4fa40f82072b1d /geyes/icons/Makefile.am
parent1ee4ea5cc7e554b481da4e052e1c7b46d03b6b5b (diff)
downloadmate-applets-914262d420e78766ae11b85403aa2247d5054d46.tar.bz2
mate-applets-914262d420e78766ae11b85403aa2247d5054d46.tar.xz
geyes: Use common subdirs - src, icons, data
Diffstat (limited to 'geyes/icons/Makefile.am')
-rw-r--r--geyes/icons/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/geyes/icons/Makefile.am b/geyes/icons/Makefile.am
new file mode 100644
index 00000000..92fa7f75
--- /dev/null
+++ b/geyes/icons/Makefile.am
@@ -0,0 +1,30 @@
+iconsdir = $(datadir)/icons/hicolor
+
+png_icons = \
+ 16x16/apps/mate-eyes-applet.png \
+ 22x22/apps/mate-eyes-applet.png \
+ 24x24/apps/mate-eyes-applet.png \
+ 32x32/apps/mate-eyes-applet.png \
+ 64x64/apps/mate-eyes-applet.png \
+ 256x256/apps/mate-eyes-applet.png \
+ $(NULL)
+
+nobase_dist_icons_DATA = \
+ $(png_icons) \
+ scalable/apps/mate-eyes-applet.svg \
+ $(NULL)
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(iconsdir)
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+
+-include $(top_srcdir)/git.mk