summaryrefslogtreecommitdiff
path: root/invest-applet/invest/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-11-14 18:24:48 -0300
committerPerberos <[email protected]>2011-11-14 18:24:48 -0300
commit312ba610a1e98fc656fb58178227d7d45a64494e (patch)
tree54a3c2b6084c80e63fb0526c6e7b8e01627acbd7 /invest-applet/invest/Makefile.am
downloadmate-applets-312ba610a1e98fc656fb58178227d7d45a64494e.tar.bz2
mate-applets-312ba610a1e98fc656fb58178227d7d45a64494e.tar.xz
initial
Diffstat (limited to 'invest-applet/invest/Makefile.am')
-rw-r--r--invest-applet/invest/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/invest-applet/invest/Makefile.am b/invest-applet/invest/Makefile.am
new file mode 100644
index 00000000..286b974c
--- /dev/null
+++ b/invest-applet/invest/Makefile.am
@@ -0,0 +1,41 @@
+invest-applet: invest-applet.py
+ sed -e "s|\@PYTHONDIR\@|$(pythondir)/|" $< > $@
+
+bin_SCRIPTS = invest-chart
+
+libexec_SCRIPTS = invest-applet
+
+investdir = $(pythondir)/invest
+invest_PYTHON = \
+ __init__.py \
+ about.py \
+ help.py \
+ applet.py \
+ chart.py \
+ currencies.py \
+ widgets.py \
+ quotes.py \
+ networkmanager.py \
+ preferences.py
+nodist_invest_PYTHON = \
+ defs.py
+
+BUILT_SOURCES = \
+ invest-applet
+
+CLEANFILES = \
+ $(BUILT_SOURCES)
+
+DISTCLEANFILES = \
+ defs.py \
+ $(CLEANFILES)
+
+EXTRA_DIST = \
+ defs.py.in \
+ invest-applet.py \
+ invest-chart \
+ test.py
+
+#TESTS = test.py
+
+-include $(top_srcdir)/git.mk