summaryrefslogtreecommitdiff
path: root/mateweather/data/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2020-12-02 10:19:16 +0100
committerraveit65 <[email protected]>2020-12-13 16:20:04 +0100
commit1f964c265a0f45c064d312dcd51f985e877cbc55 (patch)
treee7520456bc97ba82c19fdbbd9f5fd69807919069 /mateweather/data/Makefile.am
parentfbca7353191c20b3ce70fe2390491305ba3968fa (diff)
downloadmate-applets-1f964c265a0f45c064d312dcd51f985e877cbc55.tar.bz2
mate-applets-1f964c265a0f45c064d312dcd51f985e877cbc55.tar.xz
mateweather: Use common subdirs - src, data
Diffstat (limited to 'mateweather/data/Makefile.am')
-rw-r--r--mateweather/data/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/mateweather/data/Makefile.am b/mateweather/data/Makefile.am
new file mode 100644
index 00000000..4dfe4884
--- /dev/null
+++ b/mateweather/data/Makefile.am
@@ -0,0 +1,36 @@
+appletdir = $(datadir)/mate-panel/applets
+applet_in_files = org.mate.applets.MateWeatherApplet.mate-panel-applet.desktop.in
+applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
+
+$(applet_in_files): $(applet_in_files).in Makefile
+ $(AM_V_GEN)sed \
+ -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
+ -e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
+ $< > $@
+
+$(applet_DATA): $(applet_in_files) Makefile
+ $(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
+
+servicedir = $(datadir)/dbus-1/services
+service_in_files = org.mate.panel.applet.MateWeatherAppletFactory.service.in
+service_DATA = $(service_in_files:.service.in=.service)
+
+org.mate.panel.applet.MateWeatherAppletFactory.service: $(service_in_files)
+ $(AM_V_GEN)sed \
+ -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
+ $< > $@
+
+CLEANFILES = \
+ $(applet_DATA) \
+ $(applet_in_files) \
+ $(service_DATA)
+
+EXTRA_DIST = \
+ mateweather-applet-menu.xml \
+ mateweather-dialog.ui \
+ mateweather-resources.gresource.xml \
+ $(applet_in_files:=.in) \
+ $(service_in_files) \
+ $(ui_DATA)
+
+-include $(top_srcdir)/git.mk