summaryrefslogtreecommitdiff
path: root/mateweather/src/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2020-12-02 10:19:16 +0100
committerraveit65 <[email protected]>2020-12-13 16:20:04 +0100
commit1f964c265a0f45c064d312dcd51f985e877cbc55 (patch)
treee7520456bc97ba82c19fdbbd9f5fd69807919069 /mateweather/src/Makefile.am
parentfbca7353191c20b3ce70fe2390491305ba3968fa (diff)
downloadmate-applets-1f964c265a0f45c064d312dcd51f985e877cbc55.tar.bz2
mate-applets-1f964c265a0f45c064d312dcd51f985e877cbc55.tar.xz
mateweather: Use common subdirs - src, data
Diffstat (limited to 'mateweather/src/Makefile.am')
-rw-r--r--mateweather/src/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/mateweather/src/Makefile.am b/mateweather/src/Makefile.am
new file mode 100644
index 00000000..b01bc226
--- /dev/null
+++ b/mateweather/src/Makefile.am
@@ -0,0 +1,37 @@
+AM_CPPFLAGS = \
+ -I$(srcdir) \
+ -I$(top_srcdir) \
+ -DWEATHER_RESOURCE_PATH=\""/org/mate/mate-applets/mateweather/"\" \
+ $(MATE_APPLETS4_CFLAGS) \
+ $(LIBNOTIFY_CFLAGS) \
+ $(LIBMATEWEATHER_CFLAGS) \
+ ${WARN_CFLAGS}
+
+libexec_PROGRAMS = mateweather-applet
+
+BUILT_SOURCES = mateweather-resources.c mateweather-resources.h
+nodist_mateweather_applet_SOURCES = $(BUILT_SOURCES)
+mateweather_applet_SOURCES = \
+ mateweather.h \
+ main.c \
+ mateweather-about.c mateweather-about.h \
+ mateweather-pref.c mateweather-pref.h \
+ mateweather-dialog.c mateweather-dialog.h \
+ mateweather-applet.c mateweather-applet.h
+
+mateweather_applet_LDADD = \
+ $(LIBNOTIFY_LIBS) \
+ $(MATE_APPLETS4_LIBS) \
+ $(MATE_LIBS2_LIBS) \
+ $(LIBMATEWEATHER_LIBS)
+
+mateweather-resources.c: ../data/mateweather-resources.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir)/../data/ --generate-dependencies $(srcdir)/../data/mateweather-resources.gresource.xml)
+ $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir)/../data/ --generate --c-name mateweather $<
+
+mateweather-resources.h: ../data/mateweather-resources.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir)/../data/ --generate-dependencies $(srcdir)/../data/mateweather-resources.gresource.xml)
+ $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir)/../data/ --generate --c-name mateweather $<
+
+CLEANFILES = \
+ $(BUILT_SOURCES)
+
+-include $(top_srcdir)/git.mk