summaryrefslogtreecommitdiff
path: root/modemlights/Makefile.am
diff options
context:
space:
mode:
authorMartin Wimpress <[email protected]>2014-02-12 16:24:04 +0000
committerinfirit <[email protected]>2014-02-12 19:32:11 +0100
commitd7fb1cb82c5e29e1a5865045698cd845d0deb42d (patch)
tree95f7163642100ab61cd1b8daeca21707336b3f71 /modemlights/Makefile.am
parent8ec90b7ca85664810aecd9a9c6c326d207b4dafd (diff)
downloadmate-applets-d7fb1cb82c5e29e1a5865045698cd845d0deb42d.tar.bz2
mate-applets-d7fb1cb82c5e29e1a5865045698cd845d0deb42d.tar.xz
modem-lights: Remove broken modem-lights applet.
It has been broken for some time now so it is time to remove it. If someone is willing to put in the work they can resurrect it from git.
Diffstat (limited to 'modemlights/Makefile.am')
-rw-r--r--modemlights/Makefile.am103
1 files changed, 0 insertions, 103 deletions
diff --git a/modemlights/Makefile.am b/modemlights/Makefile.am
deleted file mode 100644
index 121620b8..00000000
--- a/modemlights/Makefile.am
+++ /dev/null
@@ -1,103 +0,0 @@
-#SUBDIRS = docs
-
-AM_CPPFLAGS = -I. -I$(srcdir) \
- -DMODEM_MENU_UI_DIR=\""$(uidir)"\" \
- $(MATE_APPLETS4_CFLAGS)
-
-libexec_PROGRAMS = modem_applet
-
-modem_applet_SOURCES = \
- modem-applet.c \
- modem-applet.h
-
-modem_applet_LDADD = \
- $(MATE_APPLETS4_LIBS) \
- $(MODEMLIGHTS_LIBS)
-
-uidir = $(datadir)/mate-2.0/ui
-ui_DATA = modem-applet-menu.xml
-
-
-appletdir = $(datadir)/mate-panel/applets
-applet_in_files = org.mate.applets.ModemApplet.mate-panel-applet.in
-applet_DATA = $(applet_in_files:.mate-panel-applet.in=.mate-panel-applet)
-
-$(applet_in_files): $(applet_in_files).in Makefile
- $(AM_V_GEN)sed \
- -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
- -e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
- $< > $@
-
-%.mate-panel-applet: %.mate-panel-applet.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
-
-servicedir = $(datadir)/dbus-1/services
-service_in_files = org.mate.panel.applet.ModemAppletFactory.service.in
-service_DATA = $(service_in_files:.service.in=.service)
-
-org.mate.panel.applet.ModemAppletFactory.service: $(service_in_files)
- $(AM_V_GEN)sed \
- -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
- $< > $@
-
-CLEANFILES = $(applet_DATA) $(applet_DATA).in $(service_DATA)
-
-builder_DATA = modemlights.ui
-
-icons = \
- mate-modem-monitor-applet.svg \
- mate-modem-monitor-applet.16.png \
- mate-modem-monitor-applet.32.png \
- mate-modem-monitor-applet.22.png \
- mate-modem-monitor-applet.24.png
-
-EXTRA_DIST = \
- org.mate.applets.ModemApplet.mate-panel-applet.in.in \
- $(service_in_files) \
- $(icons) \
- $(builder_DATA) \
- $(ui_DATA)
-
-gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
-
-uninstall-local:
- for icon in $(icons); do \
- SIZE=`echo $$icon | cut -d. -f2`; \
- FILE=`echo $$icon | cut -d. -f1,3`; \
- if [ "$$SIZE" = "svg" ]; then \
- SIZE="scalable"; \
- FILE="$$FILE.svg"; \
- else \
- SIZE="$${SIZE}x$${SIZE}"; \
- fi; \
- rm -f $(DESTDIR)$(iconsdir)/hicolor/$$SIZE/apps/$$FILE; \
- done
- @-if test -z "$(DESTDIR)"; then \
- echo "Updating Gtk icon cache."; \
- $(gtk_update_icon_cache); \
- else \
- echo "*** Icon cache not updated. After install, run this:"; \
- echo "*** $(gtk_update_icon_cache)"; \
- fi
-
-install-data-local:
- for icon in $(icons); do \
- SIZE=`echo $$icon | cut -d. -f2`; \
- FILE=`echo $$icon | cut -d. -f1,3`; \
- if [ "$$SIZE" = "svg" ]; then \
- SIZE="scalable"; \
- FILE="$$FILE.svg"; \
- else \
- SIZE="$${SIZE}x$${SIZE}"; \
- fi; \
- mkdir -p $(DESTDIR)$(iconsdir)/hicolor/$$SIZE/apps/; \
- $(INSTALL_DATA) $(srcdir)/$$icon $(DESTDIR)$(iconsdir)/hicolor/$$SIZE/apps/$$FILE; \
- done
- @-if test -z "$(DESTDIR)"; then \
- echo "Updating Gtk icon cache."; \
- $(gtk_update_icon_cache); \
- else \
- echo "*** Icon cache not updated. After install, run this:"; \
- echo "*** $(gtk_update_icon_cache)"; \
- fi
-
--include $(top_srcdir)/git.mk