summaryrefslogtreecommitdiff
path: root/netspeed/icons/24x24/devices/Makefile.am
diff options
context:
space:
mode:
authorVictor Kareh <[email protected]>2018-05-02 15:17:17 -0400
committerraveit65 <[email protected]>2018-05-12 22:34:48 +0200
commit3aaeec393a1fe89e7219fb4782c7a0ccef5440a2 (patch)
tree182873ec73bcd0b0187c95705ae040f7dba84e89 /netspeed/icons/24x24/devices/Makefile.am
parent683946edbdc42d9ecf97e7f6763de280aa89ece1 (diff)
downloadmate-applets-3aaeec393a1fe89e7219fb4782c7a0ccef5440a2.tar.bz2
mate-applets-3aaeec393a1fe89e7219fb4782c7a0ccef5440a2.tar.xz
netspeed: Use theme icons instead of embedded
This removes old icons included with the applet and instead uses icons from the current theme. Known issues: * Loopback interface does not have an icon, instead we use a "reload" icon to simulate it. * PLIP/SLIP interfaces do not have proper icons, I managed to find an old PLIP icon in the hicolor theme and re-purposed it. * Since not all icons have the same levels of scaling, I'm capping the size at 48px to keep all interfaces consistent. * There are no icons for Wireless Quality, so I retained the existing ones for now.
Diffstat (limited to 'netspeed/icons/24x24/devices/Makefile.am')
-rw-r--r--netspeed/icons/24x24/devices/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/netspeed/icons/24x24/devices/Makefile.am b/netspeed/icons/24x24/devices/Makefile.am
new file mode 100644
index 00000000..6e8604be
--- /dev/null
+++ b/netspeed/icons/24x24/devices/Makefile.am
@@ -0,0 +1,11 @@
+themedir = $(datadir)/icons/hicolor
+size = 24x24
+context = devices
+
+iconsdir = $(themedir)/$(size)/$(context)
+
+icons_DATA = \
+ mate-netspeed-plip.png
+
+EXTRA_DIST = \
+ $(icons_DATA)