summaryrefslogtreecommitdiff
path: root/netspeed/icons/Makefile.am
diff options
context:
space:
mode:
authormonsta <[email protected]>2015-12-11 13:43:46 +0300
committermonsta <[email protected]>2015-12-14 16:41:47 +0300
commit8aabf4f0797f7cb4a56b194b66b7c41537fcbc69 (patch)
tree4a8ced2d14dbb2e39cca6e7af7d12d8ef9554406 /netspeed/icons/Makefile.am
parent33c414812425341777454444904cecf8a525c13a (diff)
downloadmate-applets-8aabf4f0797f7cb4a56b194b66b7c41537fcbc69.tar.bz2
mate-applets-8aabf4f0797f7cb4a56b194b66b7c41537fcbc69.tar.xz
merge netspeed applet from mate-netspeed repo
Diffstat (limited to 'netspeed/icons/Makefile.am')
-rw-r--r--netspeed/icons/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/netspeed/icons/Makefile.am b/netspeed/icons/Makefile.am
new file mode 100644
index 00000000..02873848
--- /dev/null
+++ b/netspeed/icons/Makefile.am
@@ -0,0 +1,14 @@
+SUBDIRS = 16x16 22x22 24x24 32x32 48x48 scalable
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi