summaryrefslogtreecommitdiff
path: root/netspeed/icons/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2020-07-29 13:53:32 +0200
committerraveit65 <[email protected]>2020-08-11 12:41:00 +0200
commit2412123fbcb1b766aec81cb3cf4c93a3c6c4ed84 (patch)
tree6a18a6b0ed2a2f56653ab27b4bef8c674213efd3 /netspeed/icons/Makefile.am
parente095fd2471fb9b41c264e502473fea19a445b938 (diff)
downloadmate-applets-2412123fbcb1b766aec81cb3cf4c93a3c6c4ed84.tar.bz2
mate-applets-2412123fbcb1b766aec81cb3cf4c93a3c6c4ed84.tar.xz
netspeed: Simplify icons/Makefile.am
Diffstat (limited to 'netspeed/icons/Makefile.am')
-rw-r--r--netspeed/icons/Makefile.am28
1 files changed, 26 insertions, 2 deletions
diff --git a/netspeed/icons/Makefile.am b/netspeed/icons/Makefile.am
index 123b8e39..17fc4ef2 100644
--- a/netspeed/icons/Makefile.am
+++ b/netspeed/icons/Makefile.am
@@ -1,6 +1,30 @@
-SUBDIRS = 16x16 22x22 24x24 32x32 48x48 scalable
+NULL =
-gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+iconsdir = $(datadir)/icons/hicolor
+
+png_icons = \
+ 16x16/apps/mate-netspeed-applet.png \
+ 16x16/devices/mate-netspeed-plip.png \
+ 22x22/apps/mate-netspeed-applet.png \
+ 22x22/devices/mate-netspeed-plip.png \
+ 24x24/apps/mate-netspeed-applet.png \
+ 24x24/devices/mate-netspeed-plip.png \
+ 24x24/status/mate-netspeed-wireless-25.png \
+ 24x24/status/mate-netspeed-wireless-50.png \
+ 24x24/status/mate-netspeed-wireless-75.png \
+ 24x24/status/mate-netspeed-wireless-100.png \
+ 32x32/apps/mate-netspeed-applet.png \
+ 32x32/devices/mate-netspeed-plip.png \
+ 48x48/apps/mate-netspeed-applet.png \
+ 48x48/devices/mate-netspeed-plip.png \
+ $(NULL)
+
+nobase_dist_icons_DATA = \
+ $(png_icons) \
+ scalable/apps/mate-netspeed-applet.svg \
+ $(NULL)
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(iconsdir)
install-data-hook: update-icon-cache
uninstall-hook: update-icon-cache