summaryrefslogtreecommitdiff
path: root/timer-applet/src/timerapplet/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2012-06-12 17:49:56 +0200
committerStefano Karapetsas <[email protected]>2012-06-12 17:49:56 +0200
commit4bbd16182dab69da9ca7ad13309962af40529469 (patch)
treec77202017ea3739f137a86f817bdb2ecef381f80 /timer-applet/src/timerapplet/Makefile.am
parentc9b9454068f090a7132c6bea6ac07c91843ffb6e (diff)
downloadmate-applets-4bbd16182dab69da9ca7ad13309962af40529469.tar.bz2
mate-applets-4bbd16182dab69da9ca7ad13309962af40529469.tar.xz
add timer-applet
Diffstat (limited to 'timer-applet/src/timerapplet/Makefile.am')
-rw-r--r--timer-applet/src/timerapplet/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/timer-applet/src/timerapplet/Makefile.am b/timer-applet/src/timerapplet/Makefile.am
new file mode 100644
index 00000000..08f474c0
--- /dev/null
+++ b/timer-applet/src/timerapplet/Makefile.am
@@ -0,0 +1,27 @@
+SUBDIRS = controllers core ui
+
+defs.py: defs.py.in Makefile
+ sed -e "s|\@PACKAGE\@|$(PACKAGE)|" \
+ -e "s|\@VERSION\@|$(VERSION)|" \
+ -e "s|\@RESOURCESDIR\@|$(pkgdatadir)|" \
+ -e "s|\@IMAGESDIR\@|$(datadir)/pixmaps|" \
+ -e "s|\@LOCALEDIR\@|$(localedir)|" \
+ -e "s|\@GETTEXT_PACKAGE\@|$(GETTEXT_PACKAGE)|" $< > $@
+
+EXTRA_DIST = \
+ defs.py.in
+
+CLEANFILES = \
+ defs.py
+
+# Need this so that defs.py is actually created after cleaning.
+BUILT_SOURCES = defs.py
+
+moduledir = $(pythondir)/timerapplet
+module_PYTHON = \
+ __init__.py \
+ config.py \
+ defs.py \
+ utils.py \
+ logger.py
+