summaryrefslogtreecommitdiff
path: root/timerapplet/src/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2020-08-29 11:28:43 +0200
committerraveit65 <[email protected]>2020-09-05 11:59:02 +0200
commitf61476bf3632cd9af624a1832476cadc89b64411 (patch)
tree06a3fad94769b085a6cc5d2f6ee9944c63217ac3 /timerapplet/src/Makefile.am
parent02954e103de5b722c99407c68d04f77acd9e15e0 (diff)
downloadmate-applets-f61476bf3632cd9af624a1832476cadc89b64411.tar.bz2
mate-applets-f61476bf3632cd9af624a1832476cadc89b64411.tar.xz
timerapplet: Use common subdirs - src, data
Diffstat (limited to 'timerapplet/src/Makefile.am')
-rw-r--r--timerapplet/src/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/timerapplet/src/Makefile.am b/timerapplet/src/Makefile.am
new file mode 100644
index 00000000..6eb47ec9
--- /dev/null
+++ b/timerapplet/src/Makefile.am
@@ -0,0 +1,35 @@
+NULL =
+
+AM_CPPFLAGS = \
+ $(MATE_APPLETS4_CFLAGS) \
+ $(LIBNOTIFY_CFLAGS) \
+ -I$(srcdir) \
+ $(DISABLE_DEPRECATED_CFLAGS) \
+ $(NULL)
+
+libexec_PROGRAMS = timer-applet
+
+BUILT_SOURCES = timerapplet-resources.c timerapplet-resources.h
+nodist_timer_applet_SOURCES = $(BUILT_SOURCES)
+timer_applet_SOURCES = \
+ timerapplet.c \
+ $(NULL)
+
+timer_applet_LDADD = \
+ $(MATE_APPLETS4_LIBS) \
+ $(LIBNOTIFY_LIBS) \
+ $(NULL)
+
+timer_applet_CFLAGS = $(WARN_CFLAGS)
+
+timerapplet-resources.c: $(srcdir)/../data/timerapplet-resources.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir)/../data --generate-dependencies $(srcdir)/../data/timerapplet-resources.gresource.xml)
+ $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir)/../data --generate --c-name timerapplet $<
+
+timerapplet-resources.h: $(srcdir)/../data/timerapplet-resources.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir)/../data --generate-dependencies $(srcdir)/../data/timerapplet-resources.gresource.xml)
+ $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir)/../data --generate --c-name timerapplet $<
+
+CLEANFILES = \
+ $(BUILT_SOURCES) \
+ $(NULL)
+
+-include $(top_srcdir)/git.mk