summaryrefslogtreecommitdiff
path: root/trashapplet/data/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2022-08-07 10:33:33 +0200
committermouse <[email protected]>2022-08-15 10:02:36 +0800
commit927c136fab9280d095d837b93f7c34da666b550c (patch)
treec16badb8fcd7f34c3649f07b8aa809079ce61752 /trashapplet/data/Makefile.am
parenta6c354617a1e5876308df5007cd52907b3d742f9 (diff)
downloadmate-applets-927c136fab9280d095d837b93f7c34da666b550c.tar.bz2
mate-applets-927c136fab9280d095d837b93f7c34da666b550c.tar.xz
trashapplet: Add data dir
Diffstat (limited to 'trashapplet/data/Makefile.am')
-rw-r--r--trashapplet/data/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/trashapplet/data/Makefile.am b/trashapplet/data/Makefile.am
new file mode 100644
index 00000000..8603d6c2
--- /dev/null
+++ b/trashapplet/data/Makefile.am
@@ -0,0 +1,32 @@
+appletdir = $(datadir)/mate-panel/applets
+applet_in_files = org.mate.applets.TrashApplet.mate-panel-applet.desktop.in
+applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
+
+$(applet_in_files): $(applet_in_files).in Makefile
+ $(AM_V_GEN)sed \
+ -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
+ -e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
+ $< > $@
+
+$(applet_DATA): $(applet_in_files) Makefile
+ $(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
+
+servicedir = $(datadir)/dbus-1/services
+service_in_files = org.mate.panel.applet.TrashAppletFactory.service.in
+service_DATA = $(service_in_files:.service.in=.service)
+
+org.mate.panel.applet.TrashAppletFactory.service: $(service_in_files)
+ $(AM_V_GEN)sed \
+ -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
+ $< > $@
+
+EXTRA_DIST = \
+ $(applet_in_files).in \
+ $(service_in_files) \
+ trashapplet-empty-progress.ui \
+ trashapplet-menu.xml \
+ trashapplet-resources.gresource.xml
+
+CLEANFILES = $(applet_DATA) $(applet_in_files) $(service_DATA)
+
+-include $(top_srcdir)/git.mk