summaryrefslogtreecommitdiff
path: root/command/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'command/data/Makefile.am')
-rw-r--r--command/data/Makefile.am14
1 files changed, 2 insertions, 12 deletions
diff --git a/command/data/Makefile.am b/command/data/Makefile.am
index b94e9523..b6c82434 100644
--- a/command/data/Makefile.am
+++ b/command/data/Makefile.am
@@ -1,4 +1,4 @@
-APPLET_LOCATION = $(libexecdir)/command-applet
+APPLET_LOCATION = $(libdir)/mate-applets/libcommand-applet.so
appletsdir = $(datadir)/mate-panel/applets
applets_in_files = org.mate.applets.CommandApplet.mate-panel-applet.desktop.in
@@ -6,20 +6,12 @@ applets_DATA = $(applets_in_files:.mate-panel-applet.desktop.in=.mate-panel-
$(applets_in_files): $(applets_in_files).in Makefile
$(AM_V_GEN)sed \
- -e "s|\@LOCATION\@|$(APPLET_LOCATION)|" \
+ -e "s|\@APPLET_LOCATION\@|$(APPLET_LOCATION)|" \
$< > $@
$(applets_DATA): $(applets_in_files) Makefile
$(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
-servicedir = $(datadir)/dbus-1/services
-service_in_files = org.mate.panel.applet.CommandAppletFactory.service.in
-service_DATA = $(service_in_files:.service.in=.service)
-
-org.mate.panel.applet.CommandAppletFactory.service: $(service_in_files)
- $(AM_V_GEN)sed \
- -e "s|\@LOCATION\@|$(APPLET_LOCATION)|" \
- $< > $@
command_gschema_in_files = org.mate.panel.applet.command.gschema.xml.in
gsettings_SCHEMAS = $(command_gschema_in_files:.xml.in=.xml)
@@ -27,7 +19,6 @@ gsettings_SCHEMAS = $(command_gschema_in_files:.xml.in=.xml)
EXTRA_DIST = \
$(applets_in_files).in \
- $(service_in_files) \
$(command_gschema_in_files) \
command-preferences.ui \
command-resources.gresource.xml
@@ -35,7 +26,6 @@ EXTRA_DIST = \
CLEANFILES = \
$(applets_DATA) \
$(applets_in_files) \
- $(service_DATA) \
$(gsettings_SCHEMAS) \
*.gschema.valid