summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 9bd24188..ec379921 100644
--- a/configure.ac
+++ b/configure.ac
@@ -432,9 +432,14 @@ AM_CONDITIONAL(BUILD_BATTSTAT_APPLET, test x$build_battstat_applet = xyes)
dnl ***************************************************************************
dnl *** Stickynotes specific checks ***
dnl ***************************************************************************
-# AC_ARG_ENABLE(stickynotes, [ --enable-stickynotes build stickynotes
-# [@<:@default: no, transparent upgrade to Tomboy@:>@]], enable_stickynotes="yes", enable_stickynotes="no")
-enable_stickynotes="yes"
+AC_ARG_ENABLE([stickynotes],
+ AC_HELP_STRING([--enable-stickynotes], [Enable stickynotes applet.]),
+ enable_stickynotes=$enableval,
+ enable_stickynotes=yes)
+if test "x$enable_stickynotes" = "xyes"; then
+ PKG_CHECK_MODULES(STICKYNOTES, gtksourceview-$GTK_API_VERSION,
+ enable_stickynotes=yes, enable_stickynotes=no)
+fi
AM_CONDITIONAL(BUILD_STICKYNOTES_APPLET, test "x$enable_stickynotes" = "xyes")
dnl ***************************************************************************