summaryrefslogtreecommitdiff
path: root/invest-applet/data/art/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'invest-applet/data/art/Makefile.am')
-rw-r--r--invest-applet/data/art/Makefile.am59
1 files changed, 0 insertions, 59 deletions
diff --git a/invest-applet/data/art/Makefile.am b/invest-applet/data/art/Makefile.am
deleted file mode 100644
index 1a5585e5..00000000
--- a/invest-applet/data/art/Makefile.am
+++ /dev/null
@@ -1,59 +0,0 @@
-# ******************************************************************************
-# Images and icon
-# ******************************************************************************
-icons = mate-invest-applet.16.png mate-invest-applet.22.png mate-invest-applet.48.png mate-invest-applet.svg
-
-artdir = $(pkgdatadir)/invest-applet
-art_DATA = invest-16_neutral.png invest-22_neutral.png invest_neutral.svg \
- invest-22_up.png invest_up.svg \
- invest-22_down.png invest_down.svg
-
-gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
-
-uninstall-local:
- for icon in $(icons); do \
- SIZE=`echo $$icon | cut -d. -f2`; \
- FILE=`echo $$icon | cut -d. -f1,3`; \
- if [ "$$SIZE" = "svg" ]; then \
- SIZE="scalable"; \
- FILE="$$FILE.svg"; \
- else \
- SIZE="$${SIZE}x$${SIZE}"; \
- fi; \
- rm -f $(DESTDIR)$(iconsdir)/hicolor/$$SIZE/apps/$$FILE; \
- done
- @-if test -z "$(DESTDIR)"; then \
- echo "Updating Gtk icon cache."; \
- $(gtk_update_icon_cache); \
- else \
- echo "*** Icon cache not updated. After install, run this:"; \
- echo "*** $(gtk_update_icon_cache)"; \
- fi
-
-install-data-local:
- for icon in $(icons); do \
- SIZE=`echo $$icon | cut -d. -f2`; \
- FILE=`echo $$icon | cut -d. -f1,3`; \
- if [ "$$SIZE" = "svg" ]; then \
- SIZE="scalable"; \
- FILE="$$FILE.svg"; \
- else \
- SIZE="$${SIZE}x$${SIZE}"; \
- fi; \
- mkdir -p $(DESTDIR)$(iconsdir)/hicolor/$$SIZE/apps/; \
- $(INSTALL_DATA) $(srcdir)/$$icon $(DESTDIR)$(iconsdir)/hicolor/$$SIZE/apps/$$FILE; \
- done
- @-if test -z "$(DESTDIR)"; then \
- echo "Updating Gtk icon cache."; \
- $(gtk_update_icon_cache); \
- else \
- echo "*** Icon cache not updated. After install, run this:"; \
- echo "*** $(gtk_update_icon_cache)"; \
- fi
-
-EXTRA_DIST = \
- $(icons) \
- $(art_DATA)
-
-
--include $(top_srcdir)/git.mk