summaryrefslogtreecommitdiff
path: root/mateweather/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mateweather/Makefile.am')
-rw-r--r--mateweather/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/mateweather/Makefile.am b/mateweather/Makefile.am
index 9b0e27c0..db2f004c 100644
--- a/mateweather/Makefile.am
+++ b/mateweather/Makefile.am
@@ -7,14 +7,15 @@ AM_CPPFLAGS = \
-I$(top_srcdir) \
-DMATEWEATHER_MENU_UI_DIR=\""$(uidir)"\" \
$(MATE_APPLETS4_CFLAGS) \
+ $(MATEDESKTOP_CFLAGS) \
$(LIBNOTIFY_CFLAGS) \
$(LIBMATEWEATHER_CFLAGS) \
$(NETWORKMANAGER_CFLAGS) \
$(DBUS_CFLAGS)
-libexec_PROGRAMS = mateweather-applet-2
+libexec_PROGRAMS = mateweather-applet
-mateweather_applet_2_SOURCES = \
+mateweather_applet_SOURCES = \
mateweather.h \
main.c \
mateweather-about.c mateweather-about.h \
@@ -22,15 +23,16 @@ mateweather_applet_2_SOURCES = \
mateweather-dialog.c mateweather-dialog.h \
mateweather-applet.c mateweather-applet.h
-mateweather_applet_2_LDADD = \
+mateweather_applet_LDADD = \
$(LIBNOTIFY_LIBS) \
$(MATE_APPLETS4_LIBS) \
+ $(MATEDESKTOP_LIBS) \
$(MATE_LIBS2_LIBS) \
$(LIBMATEWEATHER_LIBS) \
$(NETWORKMANAGER_LIBS) \
$(DBUS_LIBS)
-uidir = $(datadir)/mate-2.0/ui
+uidir = $(datadir)/mate/ui
ui_DATA = mateweather-applet-menu.xml
appletdir = $(datadir)/mate-panel/applets