summaryrefslogtreecommitdiff
path: root/mateweather/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mateweather/data/Makefile.am')
-rw-r--r--mateweather/data/Makefile.am15
1 files changed, 4 insertions, 11 deletions
diff --git a/mateweather/data/Makefile.am b/mateweather/data/Makefile.am
index 4dfe4884..a6bf5ceb 100644
--- a/mateweather/data/Makefile.am
+++ b/mateweather/data/Makefile.am
@@ -1,36 +1,29 @@
+APPLET_LOCATION = $(libdir)/mate-applets/libmateweather-applet.so
+
appletdir = $(datadir)/mate-panel/applets
applet_in_files = org.mate.applets.MateWeatherApplet.mate-panel-applet.desktop.in
applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
$(applet_in_files): $(applet_in_files).in Makefile
$(AM_V_GEN)sed \
- -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
+ -e "s|\@APPLET_LOCATION\@|$(APPLET_LOCATION)|" \
-e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
$< > $@
$(applet_DATA): $(applet_in_files) Makefile
$(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
-servicedir = $(datadir)/dbus-1/services
-service_in_files = org.mate.panel.applet.MateWeatherAppletFactory.service.in
-service_DATA = $(service_in_files:.service.in=.service)
-org.mate.panel.applet.MateWeatherAppletFactory.service: $(service_in_files)
- $(AM_V_GEN)sed \
- -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
- $< > $@
CLEANFILES = \
$(applet_DATA) \
- $(applet_in_files) \
- $(service_DATA)
+ $(applet_in_files)
EXTRA_DIST = \
mateweather-applet-menu.xml \
mateweather-dialog.ui \
mateweather-resources.gresource.xml \
$(applet_in_files:=.in) \
- $(service_in_files) \
$(ui_DATA)
-include $(top_srcdir)/git.mk