summaryrefslogtreecommitdiff
path: root/mateweather/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mateweather/src/Makefile.am')
-rw-r--r--mateweather/src/Makefile.am21
1 files changed, 13 insertions, 8 deletions
diff --git a/mateweather/src/Makefile.am b/mateweather/src/Makefile.am
index b01bc226..d032a98f 100644
--- a/mateweather/src/Makefile.am
+++ b/mateweather/src/Makefile.am
@@ -1,3 +1,8 @@
+NULL =
+
+mateweather_applet_libdir= $(pkglibdir)
+mateweather_applet_lib_LTLIBRARIES=libmateweather-applet.la
+
AM_CPPFLAGS = \
-I$(srcdir) \
-I$(top_srcdir) \
@@ -7,23 +12,23 @@ AM_CPPFLAGS = \
$(LIBMATEWEATHER_CFLAGS) \
${WARN_CFLAGS}
-libexec_PROGRAMS = mateweather-applet
-
-BUILT_SOURCES = mateweather-resources.c mateweather-resources.h
-nodist_mateweather_applet_SOURCES = $(BUILT_SOURCES)
-mateweather_applet_SOURCES = \
+libmateweather_applet_la_SOURCES = \
mateweather.h \
main.c \
mateweather-about.c mateweather-about.h \
mateweather-pref.c mateweather-pref.h \
mateweather-dialog.c mateweather-dialog.h \
- mateweather-applet.c mateweather-applet.h
+ mateweather-applet.c mateweather-applet.h \
+ mateweather-resources.c \
+ mateweather-resources.h \
+ $(NULL)
-mateweather_applet_LDADD = \
+libmateweather_applet_la_LIBADD = \
$(LIBNOTIFY_LIBS) \
$(MATE_APPLETS4_LIBS) \
$(MATE_LIBS2_LIBS) \
- $(LIBMATEWEATHER_LIBS)
+ $(LIBMATEWEATHER_LIBS) \
+ $(NULL)
mateweather-resources.c: ../data/mateweather-resources.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir)/../data/ --generate-dependencies $(srcdir)/../data/mateweather-resources.gresource.xml)
$(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir)/../data/ --generate --c-name mateweather $<