summaryrefslogtreecommitdiff
path: root/netspeed/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'netspeed/data/Makefile.am')
-rw-r--r--netspeed/data/Makefile.am15
1 files changed, 2 insertions, 13 deletions
diff --git a/netspeed/data/Makefile.am b/netspeed/data/Makefile.am
index 350217f2..e8bec0e1 100644
--- a/netspeed/data/Makefile.am
+++ b/netspeed/data/Makefile.am
@@ -1,6 +1,6 @@
NULL =
-APPLET_LOCATION = $(libexecdir)/mate-netspeed-applet
+APPLET_LOCATION = $(libdir)/mate-applets/libmate-netspeed-applet.so
appletdir = $(datadir)/mate-panel/applets
applet_in_files = org.mate.applets.NetspeedApplet.mate-panel-applet.desktop.in
@@ -8,28 +8,18 @@ applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-ap
$(applet_in_files): $(applet_in_files).in Makefile
$(AM_V_GEN)sed \
- -e "s|\@LOCATION\@|$(APPLET_LOCATION)|" \
+ -e "s|\@APPLET_LOCATION\@|$(APPLET_LOCATION)|" \
$< > $@
$(applet_DATA): $(applet_in_files) Makefile
$(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
-servicedir = $(datadir)/dbus-1/services
-service_in_files = org.mate.panel.applet.NetspeedAppletFactory.service.in
-service_DATA = $(service_in_files:.service.in=.service)
-
-org.mate.panel.applet.NetspeedAppletFactory.service: $(service_in_files)
- $(AM_V_GEN)sed \
- -e "s|\@LOCATION\@|$(APPLET_LOCATION)|" \
- $< > $@
-
netspeed_gschema_in_files = org.mate.panel.applet.netspeed.gschema.xml.in
gsettings_SCHEMAS = $(netspeed_gschema_in_files:.xml.in=.xml)
@GSETTINGS_RULES@
EXTRA_DIST = \
$(applet_in_files).in \
- $(service_in_files) \
$(netspeed_gschema_in_files) \
netspeed-details.ui \
netspeed-menu.xml \
@@ -39,7 +29,6 @@ EXTRA_DIST = \
CLEANFILES = \
$(gsettings_SCHEMAS) \
- $(service_DATA) \
$(applet_in_files) \
$(applet_DATA)