summaryrefslogtreecommitdiff
path: root/stickynotes/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'stickynotes/Makefile.am')
-rw-r--r--stickynotes/Makefile.am28
1 files changed, 11 insertions, 17 deletions
diff --git a/stickynotes/Makefile.am b/stickynotes/Makefile.am
index 514c92eb..2057f587 100644
--- a/stickynotes/Makefile.am
+++ b/stickynotes/Makefile.am
@@ -1,5 +1,11 @@
+NULL =
+
+APPLET_LOCATION = $(libdir)/mate-applets/libmate-stickynotes-applet.so
+
SUBDIRS = pixmaps docs
+mate_stickynotes_applet_libdir= $(pkglibdir)
+mate_stickynotes_applet_lib_LTLIBRARIES=libmate-stickynotes-applet.la
applet_in_files = org.mate.applets.StickyNotesApplet.mate-panel-applet.desktop.in
service_in_files = org.mate.panel.applet.StickyNotesAppletFactory.service.in
schemas_in_files = stickynotes.schemas.in
@@ -16,9 +22,7 @@ AM_CPPFLAGS = \
${WARN_CFLAGS} \
$(NULL)
-libexec_PROGRAMS = stickynotes-applet
-
-stickynotes_applet_SOURCES = \
+libmate_stickynotes_applet_la_SOURCES = \
util.h \
util.c \
stickynotes.h \
@@ -33,7 +37,7 @@ stickynotes_applet_SOURCES = \
sticky-notes-resources.h \
$(NULL)
-stickynotes_applet_LDADD = \
+libmate_stickynotes_applet_la_LIBADD = \
$(STICKYNOTES_LIBS) \
$(MATE_APPLETS4_LIBS) \
$(LIBWNCK_LIBS) \
@@ -56,25 +60,16 @@ applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet
$(applet_in_files): $(applet_in_files:=.in) Makefile
$(AM_V_GEN)sed \
- -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
- -e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
- $< > $@
+ -e "s|\@APPLET_LOCATION\@|$(APPLET_LOCATION)|" \
+ -e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
+ $< > $@
$(applet_DATA): $(applet_in_files) Makefile
$(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
-servicedir = $(datadir)/dbus-1/services
-service_DATA = $(service_in_files:.service.in=.service)
-
-org.mate.panel.applet.StickyNotesAppletFactory.service: $(service_in_files)
- $(AM_V_GEN)sed \
- -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
- $< > $@
-
CLEANFILES = \
$(applet_DATA) \
$(applet_in_files) \
- $(service_DATA) \
$(gsettings_SCHEMAS) \
sticky-notes-resources.c \
sticky-notes-resources.h \
@@ -85,7 +80,6 @@ endif
EXTRA_DIST = \
$(stickynotes_gschema_in_files) \
- $(service_in_files) \
$(applet_in_files:=.in) \
sticky-notes-delete.ui \
sticky-notes-delete-all.ui \