summaryrefslogtreecommitdiff
path: root/timerapplet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'timerapplet/Makefile.am')
-rw-r--r--timerapplet/Makefile.am42
1 files changed, 35 insertions, 7 deletions
diff --git a/timerapplet/Makefile.am b/timerapplet/Makefile.am
index 7a69c74a..520c9553 100644
--- a/timerapplet/Makefile.am
+++ b/timerapplet/Makefile.am
@@ -1,3 +1,5 @@
+NULL =
+
AM_CPPFLAGS = \
$(MATE_APPLETS4_CFLAGS) \
$(LIBNOTIFY_CFLAGS) \
@@ -7,10 +9,26 @@ AM_CPPFLAGS = \
APPLET_LOCATION = $(libexecdir)/timer-applet
libexec_PROGRAMS = timer-applet
-timer_applet_SOURCES = timerapplet.c
-timer_applet_LDADD = $(MATE_APPLETS4_LIBS) $(LIBNOTIFY_LIBS)
+
+BUILT_SOURCES = timerapplet-resources.c timerapplet-resources.h
+nodist_timer_applet_SOURCES = $(BUILT_SOURCES)
+timer_applet_SOURCES = \
+ timerapplet.c \
+ $(NULL)
+
+timer_applet_LDADD = \
+ $(MATE_APPLETS4_LIBS) \
+ $(LIBNOTIFY_LIBS) \
+ $(NULL)
+
timer_applet_CFLAGS = $(WARN_CFLAGS)
+timerapplet-resources.c: timerapplet-resources.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir) --generate-dependencies $(srcdir)/timerapplet-resources.gresource.xml)
+ $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate --c-name timerapplet $<
+
+timerapplet-resources.h: timerapplet-resources.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir) --generate-dependencies $(srcdir)/timerapplet-resources.gresource.xml)
+ $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate --c-name timerapplet $<
+
appletsdir = $(datadir)/mate-panel/applets
applets_in_files = org.mate.applets.TimerApplet.mate-panel-applet.desktop.in
applets_DATA = $(applets_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
@@ -35,11 +53,21 @@ timer_gschema_in_files = org.mate.panel.applet.timer.gschema.xml.in
gsettings_SCHEMAS = $(timer_gschema_in_files:.xml.in=.xml)
@GSETTINGS_RULES@
-EXTRA_DIST = \
- $(applets_in_files).in \
- $(service_in_files) \
- $(timer_gschema_in_files)
+EXTRA_DIST = \
+ $(applets_in_files).in \
+ $(service_in_files) \
+ $(timer_gschema_in_files) \
+ timerapplet-preferences.ui \
+ timerapplet-resources.gresource.xml \
+ $(NULL)
-CLEANFILES = $(applets_DATA) $(applets_in_files) $(service_DATA) $(gsettings_SCHEMAS) *.gschema.valid
+CLEANFILES = \
+ $(BUILT_SOURCES) \
+ $(applets_DATA) \
+ $(applets_in_files) \
+ $(service_DATA) \
+ $(gsettings_SCHEMAS) \
+ *.gschema.valid \
+ $(NULL)
-include $(top_srcdir)/git.mk