summaryrefslogtreecommitdiff
path: root/timerapplet/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'timerapplet/src/Makefile.am')
-rw-r--r--timerapplet/src/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/timerapplet/src/Makefile.am b/timerapplet/src/Makefile.am
index 6eb47ec9..5341cc16 100644
--- a/timerapplet/src/Makefile.am
+++ b/timerapplet/src/Makefile.am
@@ -1,5 +1,8 @@
NULL =
+mate_timer_applet_libdir= $(pkglibdir)
+mate_timer_applet_lib_LTLIBRARIES=libmate-timer-applet.la
+
AM_CPPFLAGS = \
$(MATE_APPLETS4_CFLAGS) \
$(LIBNOTIFY_CFLAGS) \
@@ -7,20 +10,18 @@ AM_CPPFLAGS = \
$(DISABLE_DEPRECATED_CFLAGS) \
$(NULL)
-libexec_PROGRAMS = timer-applet
-
-BUILT_SOURCES = timerapplet-resources.c timerapplet-resources.h
-nodist_timer_applet_SOURCES = $(BUILT_SOURCES)
-timer_applet_SOURCES = \
+libmate_timer_applet_la_SOURCES = \
timerapplet.c \
+ timerapplet-resources.c \
+ timerapplet-resources.h \
$(NULL)
-timer_applet_LDADD = \
+libmate_timer_applet_la_LIBADD = \
$(MATE_APPLETS4_LIBS) \
$(LIBNOTIFY_LIBS) \
$(NULL)
-timer_applet_CFLAGS = $(WARN_CFLAGS)
+libmate_timer_applet_la_CFLAGS = $(WARN_CFLAGS)
timerapplet-resources.c: $(srcdir)/../data/timerapplet-resources.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir)/../data --generate-dependencies $(srcdir)/../data/timerapplet-resources.gresource.xml)
$(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir)/../data --generate --c-name timerapplet $<
@@ -29,7 +30,6 @@ timerapplet-resources.h: $(srcdir)/../data/timerapplet-resources.gresource.xml $
$(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir)/../data --generate --c-name timerapplet $<
CLEANFILES = \
- $(BUILT_SOURCES) \
$(NULL)
-include $(top_srcdir)/git.mk