summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorraveit65 <[email protected]>2016-04-05 15:54:29 +0200
committerraveit65 <[email protected]>2016-04-05 15:54:29 +0200
commit08eec19c27a97ca08d247f35d4773f4b6808ef32 (patch)
treed3fec40f8f270e0ea281e200d4eb981516317833 /Makefile.am
parent5a24567e16eebd55348b7d5b746dd8b9ed02ae60 (diff)
downloadmate-backgrounds-08eec19c27a97ca08d247f35d4773f4b6808ef32.tar.bz2
mate-backgrounds-08eec19c27a97ca08d247f35d4773f4b6808ef32.tar.xz
Add Changelog generation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b7c515b..d59bb5d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,5 +37,14 @@ MAINTAINERCLEANFILES = \
missing \
mkinstalldirs
+# Build ChangeLog from GIT history
+ChangeLog:
+ $(AM_V_GEN) if test -d $(top_srcdir)/.git; then \
+ GIT_DIR="$(top_srcdir)/.git" git log --stat > $@; \
+ fi
+
+dist: ChangeLog
+
+.PHONY: ChangeLog
-include $(top_srcdir)/git.mk