summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 3 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 4e60734..8b42058 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,30 +19,13 @@ dnl ###########################################################################
dnl Dependencies
dnl ###########################################################################
-GLIB_REQUIRED=2.30
+GLIB_REQUIRED=2.31
GIO_REQUIRED=2.25.10
-AC_MSG_CHECKING([which gtk+ version to compile against])
-AC_ARG_WITH([gtk],
- [AS_HELP_STRING([--with-gtk=2.0|3.0], [which gtk+ version to compile against (default: 2.0)])],
- [case "$with_gtk" in
- 2.0|3.0) ;;
- *) AC_MSG_ERROR([invalid gtk version specified]) ;;
- esac],
- [with_gtk=2.0])
-AC_MSG_RESULT([$with_gtk])
-
-case "$with_gtk" in
- 2.0) GTK_API_VERSION=2.0
- GTK_REQUIRED=2.18.0
- ;;
- 3.0) GTK_API_VERSION=3.0
- GTK_REQUIRED=2.90.4
- ;;
-esac
+GTK_REQUIRED=3.0
PKG_CHECK_MODULES(MATE_CALC, [
- gtk+-$GTK_API_VERSION >= $GTK_REQUIRED
+ gtk+-3.0 >= $GTK_REQUIRED
glib-2.0 >= $GLIB_REQUIRED
gio-2.0 >= $GIO_REQUIRED
libxml-2.0