summaryrefslogtreecommitdiff
path: root/macros/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2014-01-03 14:41:52 +0100
committerinfirit <[email protected]>2014-01-03 14:51:53 +0100
commit326dd32af1ecc9df2013b516f7f8f427a4b6cf5c (patch)
tree5ebbc06dae4c39cc345ec65106cc92356f4487b5 /macros/Makefile.am
parentda4619a11bf11b4f6c5e15d93ec796aee49916d8 (diff)
downloadmate-common-326dd32af1ecc9df2013b516f7f8f427a4b6cf5c.tar.bz2
mate-common-326dd32af1ecc9df2013b516f7f8f427a4b6cf5c.tar.xz
Add code coverage support
Add a MATE_CODE_COVERAGE m4 macro to allow projects to easily add code coverage support using lcov. This is heavily based on the code coverage tooling from GLib (LGPLv2.1+), originally written by Patrick Hulin and modified by Matthias Clasen, Stef Walter and Simon McVittie since. Adapted for use in MATE by Sander Sweers. See GNOME commit: https://git.gnome.org/browse/gnome-common/commit/?id=493d55921f26ac3a9a3b7cc33756c88daace329e And follow up commits: https://git.gnome.org/browse/gnome-common/log/macros2/gnome-code-coverage.m4
Diffstat (limited to 'macros/Makefile.am')
-rw-r--r--macros/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/macros/Makefile.am b/macros/Makefile.am
index a94ad27..534844e 100644
--- a/macros/Makefile.am
+++ b/macros/Makefile.am
@@ -2,7 +2,8 @@
MATE2_MACROS = \
mate-common.m4 \
- mate-compiler-flags.m4
+ mate-compiler-flags.m4 \
+ mate-code-coverage.m4
EXTRA_DIST = $(MATE2_MACROS) mate-autogen