summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..8697827
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,21 @@
+SUBDIRS = macros2 doc-build
+
+EXTRA_DIST = \
+ autogen.sh \
+ mate-common.doap \
+ mate-common.spec \
+ mate-common.spec.in \
+ doc/usage.txt \
+ ChangeLog.pre-git
+
+DISTCHECK_CONFIGURE_FLAGS = --disable-silent-rules
+
+# Build ChangeLog from GIT history
+ChangeLog:
+ $(AM_V_GEN) if test -d $(top_srcdir)/.git; then \
+ GIT_DIR="$(top_srcdir)/.git" git log --stat > $@; \
+ fi
+
+dist: ChangeLog
+
+.PHONY: ChangeLog