summaryrefslogtreecommitdiff
path: root/capplets/network/Makefile.am
diff options
context:
space:
mode:
authorSamuel Thibault <[email protected]>2019-05-09 18:41:39 +0200
committerraveit65 <[email protected]>2019-06-15 17:22:02 +0200
commit06970a77f4d1d7aefd9b468a4ac75f737ebf5431 (patch)
tree3f450989808ef36e2e839c377aea16b0ec9c6fcd /capplets/network/Makefile.am
parent55bc2d3f00656af5732066aa59447512882ff7ee (diff)
downloadmate-control-center-06970a77f4d1d7aefd9b468a4ac75f737ebf5431.tar.bz2
mate-control-center-06970a77f4d1d7aefd9b468a4ac75f737ebf5431.tar.xz
Add support for checking .ui accessibility with gla11y
Diffstat (limited to 'capplets/network/Makefile.am')
-rw-r--r--capplets/network/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/capplets/network/Makefile.am b/capplets/network/Makefile.am
index cb1671eb..65b7c6ec 100644
--- a/capplets/network/Makefile.am
+++ b/capplets/network/Makefile.am
@@ -1,6 +1,8 @@
# This is used in MATECC_CAPPLETS_CFLAGS
cappletname = network
+ui_files = mate-network-properties.ui
+
bin_PROGRAMS = mate-network-properties
BUILT_SOURCES = mate-network-properties-resources.h mate-network-properties-resources.c
@@ -11,6 +13,8 @@ mate_network_properties_LDADD = $(MATECC_CAPPLETS_LIBS)
@INTLTOOL_DESKTOP_RULE@
+include $(top_srcdir)/gla11y.mk
+
desktopdir = $(datadir)/applications
desktop_in_files = mate-network-properties.desktop.in
desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
@@ -22,7 +26,7 @@ AM_CPPFLAGS = \
$(MATECC_CAPPLETS_CFLAGS) \
-DMATELOCALEDIR="\"$(datadir)/locale\""
-CLEANFILES = $(MATECC_CAPPLETS_CLEANFILES) $(desktop_DATA) $(BUILT_SOURCES)
-EXTRA_DIST = mate-network-properties.ui $(desktop_in_files) org.mate.mcc.network.gresource.xml
+CLEANFILES = $(MATECC_CAPPLETS_CLEANFILES) $(desktop_DATA) $(BUILT_SOURCES) $(GLA11Y_OUTPUT)
+EXTRA_DIST = $(ui_files) $(desktop_in_files) org.mate.mcc.network.gresource.xml ui-a11y.suppr
-include $(top_srcdir)/git.mk