summaryrefslogtreecommitdiff
path: root/font-viewer/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2012-10-13 11:08:11 +0200
committerStefano Karapetsas <[email protected]>2012-10-13 11:08:11 +0200
commit2b96b475c36a35871d3a0ac13a7693eb102f5a6d (patch)
tree37a05313987970c7b2b976a283ac60aa34407ddc /font-viewer/Makefile.am
parent029158e0f2f003946c7b94f7d30bf67e443c4718 (diff)
downloadmate-control-center-2b96b475c36a35871d3a0ac13a7693eb102f5a6d.tar.bz2
mate-control-center-2b96b475c36a35871d3a0ac13a7693eb102f5a6d.tar.xz
font-viewer: replace mateconf schema with thumbnailer file
Diffstat (limited to 'font-viewer/Makefile.am')
-rw-r--r--font-viewer/Makefile.am15
1 files changed, 3 insertions, 12 deletions
diff --git a/font-viewer/Makefile.am b/font-viewer/Makefile.am
index 9fd87eac..cd941e8c 100644
--- a/font-viewer/Makefile.am
+++ b/font-viewer/Makefile.am
@@ -10,23 +10,14 @@ mate_thumbnail_font_SOURCES = ftstream-vfs.c font-thumbnailer.c totem-resources.
mate_font_viewer_LDADD = $(MATECC_CAPPLETS_LIBS) $(FONT_VIEWER_LIBS)
mate_font_viewer_SOURCES = ftstream-vfs.c font-view.c
-schemasdir = $(MATECONF_SCHEMA_FILE_DIR)
-schemas_DATA = fontilus.schemas
+thumbnailerdir = $(datadir)/thumbnailers
+thumbnailer_DATA = mate-font-viewer.thumbnailer
desktopdir = $(datadir)/applications
desktop_in_files = mate-font-viewer.desktop.in
desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
-install-data-local: install-mateconf-schemas install-desktop-database
-
-if MATECONF_SCHEMAS_INSTALL
-install-mateconf-schemas:
- if test -z "$(DESTDIR)"; then \
- MATECONF_CONFIG_SOURCE=$(MATECONF_SCHEMA_CONFIG_SOURCE) $(MATECONFTOOL) --makefile-install-rule fontilus.schemas; \
- fi
-else
-install-mateconf-schemas:
-endif
+install-data-local: install-desktop-database
install-desktop-database: install-desktopDATA
update-desktop-database $(DESTDIR)$(desktopdir)