summaryrefslogtreecommitdiff
path: root/libslab/Makefile.am
diff options
context:
space:
mode:
authorzhuyaliang <[email protected]>2023-10-25 21:43:03 +0800
committerraveit65 <[email protected]>2023-11-05 12:00:50 +0100
commitc2e94e1925f3c7acfa3fd3352dc8fdafe6375adc (patch)
tree3ba609bf57b7bb3eab18d35d78bd1dc86773fba6 /libslab/Makefile.am
parent23fc7b675ebac7a9b02257a31203974d72f584b1 (diff)
downloadmate-control-center-c2e94e1925f3c7acfa3fd3352dc8fdafe6375adc.tar.bz2
mate-control-center-c2e94e1925f3c7acfa3fd3352dc8fdafe6375adc.tar.xz
Remove libslab library
libslab is only used in mate-c-c and there is no need to provide a library
Diffstat (limited to 'libslab/Makefile.am')
-rw-r--r--libslab/Makefile.am71
1 files changed, 0 insertions, 71 deletions
diff --git a/libslab/Makefile.am b/libslab/Makefile.am
deleted file mode 100644
index df720566..00000000
--- a/libslab/Makefile.am
+++ /dev/null
@@ -1,71 +0,0 @@
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = mate-slab.pc
-
-AM_CPPFLAGS = \
- -DG_LOG_DOMAIN=\"libslab\" \
- -I$(top_srcdir) \
- $(LIBSLAB_CFLAGS) \
- $(WARN_CFLAGS)
-
-HEADER_FILES= \
- $(BUILT_SOURCES) \
- app-resizer.h \
- app-shell.h \
- application-tile.h \
- bookmark-agent.h \
- double-click-detector.h \
- mate-utils.h \
- libslab-utils.h \
- nameplate-tile.h \
- search-bar.h \
- shell-window.h \
- slab-mate-util.h \
- slab-section.h \
- slab.h \
- tile.h
-
-lib_LTLIBRARIES = libmate-slab.la
-
-libmate_slab_la_SOURCES = \
- $(MARSHAL_GENERATED) \
- app-resizer.c \
- app-shell.c \
- application-tile.c \
- bookmark-agent.c \
- double-click-detector.c \
- mate-utils.c \
- libslab-utils.c \
- nameplate-tile.c \
- search-bar.c \
- shell-window.c \
- slab-mate-util.c \
- slab-section.c \
- themed-icon.c \
- themed-icon.h \
- tile-action.c \
- tile.c
-
-libmate_slab_includedir = $(includedir)/libmate-slab
-libmate_slab_include_HEADERS = $(HEADER_FILES)
-libmate_slab_la_LIBADD = $(LIBSLAB_LIBS)
-
-MARSHAL_GENERATED = nld-marshal.c nld-marshal.h
-
-nld-marshal.h: nld-marshal.list
- ( @GLIB_GENMARSHAL@ --prefix=nld_marshal $(srcdir)/nld-marshal.list --header > nld-marshal.tmp \
- && mv nld-marshal.tmp nld-marshal.h ) \
- || ( rm -f nld-marshal.tmp && exit 1 )
-
-nld-marshal.c: nld-marshal.h
- ( (echo '#include "nld-marshal.h"'; @GLIB_GENMARSHAL@ --prefix=nld_marshal $(srcdir)/nld-marshal.list --body) > nld-marshal.tmp \
- && mv nld-marshal.tmp nld-marshal.c ) \
- || ( rm -f nld-marshal.tmp && exit 1 )
-
-
-BUILT_SOURCES = $(MARSHAL_GENERATED)
-
-CLEANFILES = $(MARSHAL_GENERATED)
-
-EXTRA_DIST = nld-marshal.list
-
--include $(top_srcdir)/git.mk