summaryrefslogtreecommitdiff
path: root/libslab/Makefile.am
diff options
context:
space:
mode:
authorZhang Xianwei <[email protected]>2018-01-07 16:07:12 +0800
committerZhang Xianwei <[email protected]>2018-01-11 09:59:45 +0800
commitafcb324eb181a9c6cb0b3c8e8589ed99391a63a0 (patch)
tree3fe5cf0b331c06cb7b86c658e41a548cd2bbc460 /libslab/Makefile.am
parenta34ea4de6c653e184bf5eeef17dd2d73a9955fb1 (diff)
downloadmate-control-center-afcb324eb181a9c6cb0b3c8e8589ed99391a63a0.tar.bz2
mate-control-center-afcb324eb181a9c6cb0b3c8e8589ed99391a63a0.tar.xz
libslab: fix search icon misaligned
Make use GtkSearchEntry instead of builtin NldSearchEntry fixes #299 Signed-off-by: Zhang Xianwei <[email protected]>
Diffstat (limited to 'libslab/Makefile.am')
-rw-r--r--libslab/Makefile.am21
1 files changed, 3 insertions, 18 deletions
diff --git a/libslab/Makefile.am b/libslab/Makefile.am
index e4f2ffdc..93a728d0 100644
--- a/libslab/Makefile.am
+++ b/libslab/Makefile.am
@@ -18,7 +18,6 @@ HEADER_FILES= \
nameplate-tile.h \
search-bar.h \
search-context-picker.h \
- search-entry.h \
shell-window.h \
slab-mate-util.h \
slab-section.h \
@@ -39,8 +38,6 @@ libmate_slab_la_SOURCES = \
nameplate-tile.c \
search-bar.c \
search-context-picker.c \
- search-entry-watermark.h \
- search-entry.c \
shell-window.c \
slab-mate-util.c \
slab-section.c \
@@ -53,12 +50,6 @@ libmate_slab_includedir = $(includedir)/libmate-slab
libmate_slab_include_HEADERS = $(HEADER_FILES)
libmate_slab_la_LIBADD = $(LIBSLAB_LIBS)
-search-entry-watermark.h: search-entry-watermark.svg
- echo '#define SEARCH_ENTRY_WATERMARK_SVG "\' > $@; \
- sed -e 's/"/\\"/g' -e 's/$$/\\/' -e 's/#000000/#%s/g' $< >> $@; \
- echo '"' >> $@
-
-
MARSHAL_GENERATED = nld-marshal.c nld-marshal.h
nld-marshal.h: nld-marshal.list
@@ -72,16 +63,10 @@ nld-marshal.c: nld-marshal.h
|| ( rm -f nld-marshal.tmp && exit 1 )
-BUILT_SOURCES = \
- search-entry-watermark.h \
- $(MARSHAL_GENERATED)
+BUILT_SOURCES = $(MARSHAL_GENERATED)
-CLEANFILES = \
- search-entry-watermark.h \
- $(MARSHAL_GENERATED)
+CLEANFILES = $(MARSHAL_GENERATED)
-EXTRA_DIST= \
- search-entry-watermark.svg \
- nld-marshal.list
+EXTRA_DIST = nld-marshal.list
-include $(top_srcdir)/git.mk