summaryrefslogtreecommitdiff
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2021-02-13 12:32:06 +0100
committerraveit65 <[email protected]>2021-02-16 14:07:47 +0100
commite50a1907e04a320bf9e054182b8dbeb4c52eb076 (patch)
treef0c11e26e732a7693149229c6d5fd7449149b35b /shell/Makefile.am
parent68306612ea6c7dc8635290950ce435a459dd4568 (diff)
downloadmate-control-center-e50a1907e04a320bf9e054182b8dbeb4c52eb076.tar.bz2
mate-control-center-e50a1907e04a320bf9e054182b8dbeb4c52eb076.tar.xz
build: allow users to disable gettext support (--disable-nls)
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 77d1c1ac..d3e4d8bd 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -21,13 +21,21 @@ sysdir = $(datadir)/applications
sys_in_files = matecc.desktop.in
sys_DATA = $(sys_in_files:.desktop.in=.desktop)
$(sys_DATA): $(sys_in_files)
+if USE_NLS
$(AM_V_GEN) $(MSGFMT) --desktop --keyword= --keyword=Name --keyword=Comment --keyword=Keywords --template $< -d $(top_srcdir)/po -o $@
+else
+ $(AM_V_GEN) sed '/^# Translators/d' < $< > $@
+endif
directorydir = $(datadir)/desktop-directories
directory_in_files = matecc.directory.desktop.in
directory_DATA = $(directory_in_files:.directory.desktop.in=.directory)
$(directory_DATA): $(directory_in_files)
+if USE_NLS
$(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+else
+ $(AM_V_GEN) sed '/^# Translators/d' < $< > $@
+endif
menudir = $(sysconfdir)/xdg/menus
menu_DATA = matecc.menu