summaryrefslogtreecommitdiff
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-12-01 21:51:44 -0300
committerPerberos <[email protected]>2011-12-01 21:51:44 -0300
commit0b0e6bc987da4fd88a7854ebb12bde705e92c428 (patch)
tree47d329edd31c67eaa36b2147780e37e197e901b5 /shell/Makefile.am
downloadmate-control-center-0b0e6bc987da4fd88a7854ebb12bde705e92c428.tar.bz2
mate-control-center-0b0e6bc987da4fd88a7854ebb12bde705e92c428.tar.xz
moving from https://github.com/perberos/mate-desktop-environment
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
new file mode 100644
index 00000000..db58a1f4
--- /dev/null
+++ b/shell/Makefile.am
@@ -0,0 +1,56 @@
+if HAVE_LIBSLAB_DEPS
+REAL_LIBSLAB_CFLAGS = -I$(top_srcdir)/libslab
+REAL_LIBSLAB_LIBS = $(top_builddir)/libslab/libslab.la
+else
+REAL_LIBSLAB_CFLAGS = $(EXTERNAL_LIBSLAB_CFLAGS)
+REAL_LIBSLAB_LIBS = $(EXTERNAL_LIBSLAB_LIBS)
+endif
+
+INCLUDES = \
+ -I$(top_srcdir) \
+ $(REAL_LIBSLAB_CFLAGS) \
+ $(MATECC_SHELL_CFLAGS)
+
+bin_PROGRAMS = mate-control-center
+
+mate_control_center_SOURCES = \
+ control-center.c
+
+mate_control_center_LDADD = \
+ $(MATECC_SHELL_LIBS) \
+ $(REAL_LIBSLAB_LIBS)
+
+AM_CPPFLAGS = \
+ -DMATELOCALEDIR="\"$(datadir)/locale\""
+
+sysdir = $(datadir)/applications
+sys_in_files = matecc.desktop.in
+sys_DATA = $(sys_in_files:.desktop.in=.desktop)
+@INTLTOOL_DESKTOP_RULE@
+
+directorydir = $(datadir)/desktop-directories
+directory_in_files = matecc.directory.in
+directory_DATA = $(directory_in_files:.directory.in=.directory)
+@INTLTOOL_DIRECTORY_RULE@
+
+schemasdir = @MATECONF_SCHEMA_FILE_DIR@
+schemas_DATA = control-center.schemas
+@INTLTOOL_SCHEMAS_RULE@
+
+install-data-local: $(schema_DATA)
+if MATECONF_SCHEMAS_INSTALL
+ if test -z "$(DESTDIR)" ; then \
+ for p in $^ ; do \
+ MATECONF_CONFIG_SOURCE=$(MATECONF_SCHEMA_CONFIG_SOURCE) $(MATECONFTOOL) --makefile-install-rule $$p 2>&1 > /dev/null; \
+ done \
+ fi
+endif
+
+menudir = $(sysconfdir)/xdg/menus
+menu_DATA = matecc.menu
+
+EXTRA_DIST = matecc.desktop.in.in matecc.directory.in matecc.menu $(schemas_DATA).in
+
+DISTCLEANFILES = matecc.desktop matecc.desktop.in matecc.directory $(schemas_DATA)
+
+-include $(top_srcdir)/git.mk