summaryrefslogtreecommitdiff
path: root/capplets/about-me/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'capplets/about-me/Makefile.am')
-rw-r--r--capplets/about-me/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/capplets/about-me/Makefile.am b/capplets/about-me/Makefile.am
index f510c81f..01b07f95 100644
--- a/capplets/about-me/Makefile.am
+++ b/capplets/about-me/Makefile.am
@@ -28,6 +28,9 @@ marshal.c: fprintd-marshal.list
bin_PROGRAMS = mate-about-me
mate_about_me_LDADD = $(MATECC_CAPPLETS_LIBS)
+if HAVE_ACCOUNTSSERVICE
+mate_about_me_LDADD += $(ACCOUNTSSERVICE_LIBS)
+endif
mate_about_me_LDFLAGS = -export-dynamic
@INTLTOOL_DESKTOP_RULE@
@@ -47,6 +50,11 @@ AM_CPPFLAGS = \
-DMATECC_PIXMAP_DIR="\"$(pkgdatadir)/pixmaps\"" \
-DMATELOCALEDIR="\"$(datadir)/locale\""
+if HAVE_ACCOUNTSSERVICE
+AM_CPPFLAGS += \
+ $(ACCOUNTSSERVICE_CFLAGS)
+endif
+
CLEANFILES = $(MATECC_CAPPLETS_CLEANFILES) $(desktop_DATA) $(MARSHALFILES)
EXTRA_DIST = $(ui_files) fprintd-marshal.list