summaryrefslogtreecommitdiff
path: root/capplets/keybindings/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'capplets/keybindings/Makefile.am')
-rw-r--r--capplets/keybindings/Makefile.am20
1 files changed, 13 insertions, 7 deletions
diff --git a/capplets/keybindings/Makefile.am b/capplets/keybindings/Makefile.am
index 9501dd8f..24c95a56 100644
--- a/capplets/keybindings/Makefile.am
+++ b/capplets/keybindings/Makefile.am
@@ -4,6 +4,9 @@ cappletname = keybinding
bin_PROGRAMS = mate-keybinding-properties
mate_keybinding_properties_LDADD = $(MATECC_CAPPLETS_LIBS)
+BUILT_SOURCES = mate-keybinding-properties-resources.h mate-keybinding-properties-resources.c
+nodist_mate_keybinding_properties_SOURCES = \
+ $(BUILT_SOURCES)
mate_keybinding_properties_SOURCES = \
mate-keybinding-properties.c \
eggcellrendererkeys.c \
@@ -13,9 +16,6 @@ mate_keybinding_properties_SOURCES = \
@INTLTOOL_DESKTOP_RULE@
-uidir = $(pkgdatadir)/ui
-ui_DATA = mate-keybinding-properties.ui
-
desktopdir = $(datadir)/applications
Desktop_in_files = mate-keybinding.desktop.in
desktop_DATA = $(Desktop_in_files:.desktop.in=.desktop)
@@ -29,16 +29,22 @@ xml_DATA = $(xml_in_files:.xml.in=.xml)
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = mate-keybindings.pc
+mate-keybinding-properties-resources.h mate-keybinding-properties-resources.c: org.mate.mcc.keybindings.gresource.xml Makefile $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies --sourcedir $(srcdir) $(srcdir)/org.mate.mcc.keybindings.gresource.xml)
+ $(AM_V_GEN) XMLLINT=$(XMLLINT) $(GLIB_COMPILE_RESOURCES) --target $@ --sourcedir $(srcdir) --generate --c-name keybindings $<
+
AM_CPPFLAGS = \
$(MATECC_CAPPLETS_CFLAGS) \
-DMATELOCALEDIR="\"$(datadir)/locale\"" \
- -DMATECC_DATA_DIR="\"$(pkgdatadir)\"" \
- -DMATECC_UI_DIR="\"$(uidir)\""
+ -DMATECC_DATA_DIR="\"$(pkgdatadir)\""
CLEANFILES = \
+ $(BUILT_SOURCES) \
$(MATECC_CAPPLETS_CLEANFILES) \
$(desktop_DATA) \
$(xml_DATA)
-EXTRA_DIST = $(ui_DATA) $(xml_in_files) mate-keybindings.pc.in $(Desktop_in_files)
-
+EXTRA_DIST = $(xml_in_files) \
+ mate-keybindings.pc.in \
+ mate-keybinding-properties.ui \
+ $(Desktop_in_files) \
+ org.mate.mcc.keybindings.gresource.xml
-include $(top_srcdir)/git.mk