summaryrefslogtreecommitdiff
path: root/capplets/keyboard/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'capplets/keyboard/Makefile.am')
-rw-r--r--capplets/keyboard/Makefile.am27
1 files changed, 16 insertions, 11 deletions
diff --git a/capplets/keyboard/Makefile.am b/capplets/keyboard/Makefile.am
index b1a7c5af..30c77705 100644
--- a/capplets/keyboard/Makefile.am
+++ b/capplets/keyboard/Makefile.am
@@ -3,6 +3,9 @@ cappletname = keyboard
bin_PROGRAMS = mate-keyboard-properties
+BUILT_SOURCES = mate-keyboard-properties-resources.h mate-keyboard-properties-resources.c
+nodist_mate_keyboard_properties_SOURCES = \
+ $(BUILT_SOURCES)
mate_keyboard_properties_SOURCES = \
mate-keyboard-properties.c \
mate-keyboard-properties-a11y.c \
@@ -19,24 +22,26 @@ mate_keyboard_properties_LDADD = $(MATECC_CAPPLETS_LIBS) $(LIBMATEKBDUI_LIBS)
@INTLTOOL_DESKTOP_RULE@
-uidir = $(pkgdatadir)/ui
-dist_ui_DATA = mate-keyboard-properties-a11y-notifications.ui \
- mate-keyboard-properties-dialog.ui \
- mate-keyboard-properties-layout-chooser.ui \
- mate-keyboard-properties-model-chooser.ui \
- mate-keyboard-properties-options-dialog.ui
-
desktopdir = $(datadir)/applications
Desktop_in_files = mate-keyboard.desktop.in
desktop_DATA = $(Desktop_in_files:.desktop.in=.desktop)
+mate-keyboard-properties-resources.h mate-keyboard-properties-resources.c: org.mate.mcc.keyboard.gresource.xml Makefile $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies --sourcedir $(srcdir) $(srcdir)/org.mate.mcc.keyboard.gresource.xml)
+ $(AM_V_GEN) XMLLINT=$(XMLLINT) $(GLIB_COMPILE_RESOURCES) --target $@ --sourcedir $(srcdir) --generate --c-name keyboard $<
+
AM_CPPFLAGS = \
$(MATECC_CAPPLETS_CFLAGS) \
$(LIBMATEKBDUI_CFLAGS) \
-DMATELOCALEDIR="\"$(datadir)/locale\"" \
- -DMATECC_DATA_DIR="\"$(pkgdatadir)\"" \
- -DMATECC_UI_DIR="\"$(uidir)\""
-CLEANFILES = $(MATECC_CAPPLETS_CLEANFILES) $(desktop_DATA)
-EXTRA_DIST = $(ui_DATA) $(Desktop_in_files)
+ -DMATECC_DATA_DIR="\"$(pkgdatadir)\""
+CLEANFILES = $(MATECC_CAPPLETS_CLEANFILES) $(desktop_DATA) $(BUILT_SOURCES)
+EXTRA_DIST = \
+ mate-keyboard-properties-a11y-notifications.ui \
+ mate-keyboard-properties-dialog.ui \
+ mate-keyboard-properties-layout-chooser.ui \
+ mate-keyboard-properties-model-chooser.ui \
+ mate-keyboard-properties-options-dialog.ui \
+ $(Desktop_in_files) \
+ org.mate.mcc.keyboard.gresource.xml
-include $(top_srcdir)/git.mk