summaryrefslogtreecommitdiff
path: root/capplets/network/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'capplets/network/meson.build')
-rw-r--r--capplets/network/meson.build35
1 files changed, 35 insertions, 0 deletions
diff --git a/capplets/network/meson.build b/capplets/network/meson.build
new file mode 100644
index 00000000..5fa40544
--- /dev/null
+++ b/capplets/network/meson.build
@@ -0,0 +1,35 @@
+desktop = 'mate-network-properties.desktop'
+
+i18n.merge_file(
+ type: 'desktop',
+ input: desktop + '.in',
+ output: desktop,
+ po_dir: po_dir,
+ install: true,
+ install_dir: mcc_desktopdir
+)
+
+sources = files(
+ 'mate-network-properties.c',
+)
+
+sources += gnome.compile_resources(
+ 'mate-network-properties-resources',
+ 'org.mate.mcc.network.gresource.xml',
+ c_name: 'network',
+ export: true
+)
+
+cflags += [
+ '-DMATECC_DATA_DIR="@0@"'.format(mcc_pkgdatadir),
+]
+
+executable(
+ 'mate-network-properties',
+ sources : sources,
+ include_directories: config_inc,
+ dependencies : [common_deps, libcommon_dep],
+ c_args : cflags,
+ install : true,
+ install_dir : get_option('bindir')
+)