summaryrefslogtreecommitdiff
path: root/capplets/windows/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'capplets/windows/Makefile.am')
-rw-r--r--capplets/windows/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/capplets/windows/Makefile.am b/capplets/windows/Makefile.am
index 92175d2c..4c505a11 100644
--- a/capplets/windows/Makefile.am
+++ b/capplets/windows/Makefile.am
@@ -5,6 +5,8 @@ bin_PROGRAMS = mate-window-properties
mate_window_properties_LDADD = $(MATECC_CAPPLETS_LIBS)
+BUILT_SOURCES = mate-window-properties-resources.h mate-window-properties-resources.c
+nodist_mate_window_properties_SOURCES = $(BUILT_SOURCES)
mate_window_properties_SOURCES = \
mate-metacity-support.h \
mate-metacity-support.c \
@@ -14,6 +16,9 @@ desktopdir = $(datadir)/applications
Desktop_in_files = mate-window-properties.desktop.in
desktop_DATA = $(Desktop_in_files:.desktop.in=.desktop)
+mate-window-properties-resources.h mate-window-properties-resources.c: org.mate.mcc.windows.gresource.xml Makefile $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies --sourcedir $(srcdir) $(srcdir)/org.mate.mcc.windows.gresource.xml)
+ $(AM_V_GEN) XMLLINT=$(XMLLINT) $(GLIB_COMPILE_RESOURCES) --target $@ --sourcedir $(srcdir) --generate --c-name window_properties $<
+
$(desktop_DATA): $(Desktop_in_files)
$(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
@@ -21,7 +26,7 @@ AM_CPPFLAGS = $(MATECC_CAPPLETS_CFLAGS) \
-DUIDIR=\""$(uidir)"\" \
-DPIXMAPDIR=\""$(pixmapdir)"\"
-CLEANFILES = $(MATECC_CAPPLETS_CLEANFILES) $(desktop_DATA)
-EXTRA_DIST = $(Desktop_in_files)
+CLEANFILES = $(BUILT_SOURCES) $(MATECC_CAPPLETS_CLEANFILES) $(desktop_DATA)
+EXTRA_DIST = $(Desktop_in_files) org.mate.mcc.windows.gresource.xml window-properties.ui
-include $(top_srcdir)/git.mk