summaryrefslogtreecommitdiff
path: root/font-viewer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'font-viewer/Makefile.am')
-rw-r--r--font-viewer/Makefile.am15
1 files changed, 3 insertions, 12 deletions
diff --git a/font-viewer/Makefile.am b/font-viewer/Makefile.am
index 9fd87eac..cd941e8c 100644
--- a/font-viewer/Makefile.am
+++ b/font-viewer/Makefile.am
@@ -10,23 +10,14 @@ mate_thumbnail_font_SOURCES = ftstream-vfs.c font-thumbnailer.c totem-resources.
mate_font_viewer_LDADD = $(MATECC_CAPPLETS_LIBS) $(FONT_VIEWER_LIBS)
mate_font_viewer_SOURCES = ftstream-vfs.c font-view.c
-schemasdir = $(MATECONF_SCHEMA_FILE_DIR)
-schemas_DATA = fontilus.schemas
+thumbnailerdir = $(datadir)/thumbnailers
+thumbnailer_DATA = mate-font-viewer.thumbnailer
desktopdir = $(datadir)/applications
desktop_in_files = mate-font-viewer.desktop.in
desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
-install-data-local: install-mateconf-schemas install-desktop-database
-
-if MATECONF_SCHEMAS_INSTALL
-install-mateconf-schemas:
- if test -z "$(DESTDIR)"; then \
- MATECONF_CONFIG_SOURCE=$(MATECONF_SCHEMA_CONFIG_SOURCE) $(MATECONFTOOL) --makefile-install-rule fontilus.schemas; \
- fi
-else
-install-mateconf-schemas:
-endif
+install-data-local: install-desktop-database
install-desktop-database: install-desktopDATA
update-desktop-database $(DESTDIR)$(desktopdir)