summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMonsta <[email protected]>2015-06-30 14:06:36 +0300
committerMonsta <[email protected]>2015-07-07 10:45:45 +0300
commit11dd67f846956c4fcf09b37b2e3e489f76ae65d8 (patch)
tree2ecacc7dc4228f18e3f6940a2061b1dc4553600b /configure.ac
parent18885e66858446d016091e6f0f33c760823a163c (diff)
downloadmate-desktop-11dd67f846956c4fcf09b37b2e3e489f76ae65d8.tar.bz2
mate-desktop-11dd67f846956c4fcf09b37b2e3e489f76ae65d8.tar.xz
Resurrect the old user-guide as it's complete and translated
Big thanks to @NiceandGently for doing most of the work on this :)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 07f2027..7eeaf96 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,11 +77,19 @@ fi
# Should we build mate-about? Useful for people who need to build
# two mate-desktop using two different versions of GTK+
AC_ARG_ENABLE([mate-about],
- [AS_HELP_STRING([--disable-mate-about],[dont build mate-about])],,
+ [AS_HELP_STRING([--disable-mate-about],[do not build mate-about])],,
[enable_mate_about=yes])
AM_CONDITIONAL(MATE_ABOUT_ENABLED, test "x$enable_mate_about" = "xyes")
+# Should we build the docbook user-guide? Will be useful until
+# the new mallard mate-user-guide is complete and translated
+AC_ARG_ENABLE([user-guide],
+ [AS_HELP_STRING([--disable-user-guide],[do not build user guide])],,
+ [enable_user_guide=yes])
+AM_CONDITIONAL(USER_GUIDE_ENABLED, test "x$enable_user_guide" = "xyes")
+
+
# Install tool to migrate 1.4 MateConf settings
AC_ARG_ENABLE([mate-conf-import],
[AS_HELP_STRING([--enable-mate-conf-import],[install mate-conf-import tool])],,
@@ -302,6 +310,8 @@ man/Makefile
tools/mate-color-select.desktop.in
tools/mate-conf-import.desktop.in
tools/Makefile
+user-guide/Makefile
+user-guide/mate-user-guide.desktop.in
])
AC_OUTPUT
@@ -330,6 +340,7 @@ mate-desktop $VERSION
Gtk+ version: ${GTK_API_VERSION}
Build mate-about: ${enable_mate_about}
+ Build user guide: ${enable_user_guide}
Install mate-conf-import: ${enable_mate_conf_import}
Install mpaste: ${enable_mpaste}
Use external pnp.ids: ${EXTERNAL_PNP_IDS}