summaryrefslogtreecommitdiff
path: root/icons/Makefile.am
diff options
context:
space:
mode:
authorBalló György <[email protected]>2015-07-29 10:00:19 +0200
committerinfirit <[email protected]>2015-09-14 15:59:49 +0200
commitb838c8c828d2d4e988b10b18f5f734f29bcac28c (patch)
tree7a5ce6b1985220ef8517626be916d09952f8f585 /icons/Makefile.am
parent448b18d3405df9dce20a61edfb9004284db4e50f (diff)
downloadmate-desktop-b838c8c828d2d4e988b10b18f5f734f29bcac28c.tar.bz2
mate-desktop-b838c8c828d2d4e988b10b18f5f734f29bcac28c.tar.xz
Fix missing icons on GTK3 with custom icon theme
Diffstat (limited to 'icons/Makefile.am')
-rw-r--r--icons/Makefile.am59
1 files changed, 59 insertions, 0 deletions
diff --git a/icons/Makefile.am b/icons/Makefile.am
new file mode 100644
index 0000000..786bb26
--- /dev/null
+++ b/icons/Makefile.am
@@ -0,0 +1,59 @@
+NULL =
+
+public_icons_themes = \
+ hicolor \
+ $(NULL)
+
+public_icons = \
+ hicolor_apps_16x16_mate.png \
+ hicolor_apps_22x22_mate.png \
+ hicolor_apps_24x24_mate.png \
+ hicolor_apps_32x32_mate.png \
+ hicolor_apps_48x48_mate.png \
+ hicolor_apps_256x256_mate.png \
+ hicolor_apps_scalable_mate-symbolic.svg \
+ $(NULL)
+
+EXTRA_DIST = \
+ $(public_icons) \
+ $(NULL)
+
+###############################################################################
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t
+
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ for theme in $(public_icons_themes); do \
+ $(gtk_update_icon_cache) $(datadir)/icons/$$theme; \
+ done; \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ for theme in $(public_icons_themes); do \
+ echo "*** $(gtk_update_icon_cache) $(datadir)/icons/$$theme"; \
+ done; \
+ fi
+
+install-icons:
+ for icon in $(public_icons); do \
+ THEME=`echo $$icon | cut -d_ -f1`; \
+ CONTEXT=`echo $$icon | cut -d_ -f2`; \
+ SIZE=`echo $$icon | cut -d_ -f3`; \
+ ICONFILE=`echo $$icon | cut -d_ -f4`; \
+ mkdir -p $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT; \
+ $(INSTALL_DATA) $(srcdir)/$$icon $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
+ done
+
+uninstall-icons:
+ -for icon in $(public_icons); do \
+ THEME=`echo $$icon | cut -d_ -f1`; \
+ CONTEXT=`echo $$icon | cut -d_ -f2`; \
+ SIZE=`echo $$icon | cut -d_ -f3`; \
+ ICONFILE=`echo $$icon | cut -d_ -f4`; \
+ rm -f $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
+ done
+
+install-data-local: install-icons update-icon-cache
+
+uninstall-local: uninstall-icons update-icon-cache