summaryrefslogtreecommitdiff
path: root/libmate-desktop/Makefile.am
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2019-05-28 14:29:42 +0800
committerraveit65 <[email protected]>2019-06-11 16:06:41 +0200
commit451baa964b34accd93af19ab8c6aa93636bf79fd (patch)
tree864225e365b684f40d4cda42a20ec61462a59a16 /libmate-desktop/Makefile.am
parentd53d2be25eded44f81c126c9d904d21774f7ee42 (diff)
downloadmate-desktop-451baa964b34accd93af19ab8c6aa93636bf79fd.tar.bz2
mate-desktop-451baa964b34accd93af19ab8c6aa93636bf79fd.tar.xz
Add test code for mate-languages.
Diffstat (limited to 'libmate-desktop/Makefile.am')
-rw-r--r--libmate-desktop/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/libmate-desktop/Makefile.am b/libmate-desktop/Makefile.am
index b6698e5..48d7378 100644
--- a/libmate-desktop/Makefile.am
+++ b/libmate-desktop/Makefile.am
@@ -31,7 +31,7 @@ AM_CPPFLAGS = \
AM_CFLAGS = $(WARN_CFLAGS)
-noinst_PROGRAMS = test-ditem test
+noinst_PROGRAMS = test-ditem test test-languages
CLEANFILES =
@@ -87,6 +87,12 @@ test_ditem_LDADD = \
$(XLIB_LIBS) \
$(MATE_DESKTOP_LIBS)
+test_languages_SOURCES = test-languages.c
+
+test_languages_LDADD = \
+ libmate-desktop-2.la \
+ $(MATE_DESKTOP_LIBS)
+
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = mate-desktop-2.0.pc