summaryrefslogtreecommitdiff
path: root/libmate-desktop/Makefile.am
diff options
context:
space:
mode:
authorJasmine Hassan <[email protected]>2012-11-11 06:38:09 +0200
committerJasmine Hassan <[email protected]>2012-11-11 08:01:15 +0200
commitbfc5cbef4b0d3a95246d38af041f668068afda57 (patch)
treef27144e1a667e0440499b0a7522f2a5ceed08ac5 /libmate-desktop/Makefile.am
parentc0080bd8df9c7e0edb7d3a406a40336e4229ac82 (diff)
downloadmate-desktop-bfc5cbef4b0d3a95246d38af041f668068afda57.tar.bz2
mate-desktop-bfc5cbef4b0d3a95246d38af041f668068afda57.tar.xz
[build] Update all Makefile.am to more recent standards
http://git.gnome.org/browse/gnome-desktop/commit/?id=4c3d78c930ecb833a677f534ef6cd697d3d92169
Diffstat (limited to 'libmate-desktop/Makefile.am')
-rw-r--r--libmate-desktop/Makefile.am18
1 files changed, 10 insertions, 8 deletions
diff --git a/libmate-desktop/Makefile.am b/libmate-desktop/Makefile.am
index 322963e..4007291 100644
--- a/libmate-desktop/Makefile.am
+++ b/libmate-desktop/Makefile.am
@@ -1,14 +1,16 @@
SUBDIRS = libmate libmateui
-INCLUDES = \
- -DMATELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale\"" \
- -DPNP_IDS=\""$(PNP_IDS)"\" \
- $(WARN_CFLAGS) \
- $(DISABLE_DEPRECATED) \
+lib_LTLIBRARIES = libmate-desktop-2.la
+
+AM_CPPFLAGS = \
+ $(MATE_DESKTOP_CFLAGS) \
$(XLIB_CFLAGS) \
- $(MATE_DESKTOP_CFLAGS)
+ -DG_LOG_DOMAIN=\"MateDesktop\" \
+ -DMATELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale\"" \
+ -DPNP_IDS=\""$(PNP_IDS)"\" \
+ $(DISABLE_DEPRECATED)
-lib_LTLIBRARIES = libmate-desktop-2.la
+AM_CFLAGS = $(WARN_CFLAGS)
noinst_PROGRAMS = test-ditem
@@ -47,11 +49,11 @@ test_ditem_LDADD = \
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = mate-desktop-2.0.pc
-pnpdata_DATA_dist = pnp.ids
if USE_INTERNAL_PNP_IDS
pnpdatadir = $(datadir)/libmate-desktop
pnpdata_DATA = pnp.ids
endif
+pnpdata_DATA_dist = pnp.ids
check:
test -s $(top_srcdir)/libmate-desktop/pnp.ids