summaryrefslogtreecommitdiff
path: root/libmate-desktop/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2012-11-15 08:26:24 -0800
committerStefano Karapetsas <[email protected]>2012-11-15 08:26:24 -0800
commit86a51f1ba55208272a50e17ac94f745907131758 (patch)
tree93d19d85feadd31f2027f09557447998ebd42bda /libmate-desktop/Makefile.am
parent30ec51cebbfaa251bff071e39ab777af012cb015 (diff)
parent39d84d1c8a3ff07d20126f7220b7a3bfec5e306a (diff)
downloadmate-desktop-86a51f1ba55208272a50e17ac94f745907131758.tar.bz2
mate-desktop-86a51f1ba55208272a50e17ac94f745907131758.tar.xz
Merge pull request #36 from jasmineaura/develop
Properly support GTK3, simplify GTK2 compat, and some fixes
Diffstat (limited to 'libmate-desktop/Makefile.am')
-rw-r--r--libmate-desktop/Makefile.am18
1 files changed, 10 insertions, 8 deletions
diff --git a/libmate-desktop/Makefile.am b/libmate-desktop/Makefile.am
index 322963e..878303d 100644
--- a/libmate-desktop/Makefile.am
+++ b/libmate-desktop/Makefile.am
@@ -1,14 +1,16 @@
SUBDIRS = libmate libmateui
-INCLUDES = \
- -DMATELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale\"" \
- -DPNP_IDS=\""$(PNP_IDS)"\" \
- $(WARN_CFLAGS) \
- $(DISABLE_DEPRECATED) \
+lib_LTLIBRARIES = libmate-desktop-2.la
+
+AM_CPPFLAGS = \
+ $(MATE_DESKTOP_CFLAGS) \
$(XLIB_CFLAGS) \
- $(MATE_DESKTOP_CFLAGS)
+ -DG_LOG_DOMAIN=\"MateDesktop\" \
+ -DMATELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale\"" \
+ -DPNP_IDS=\""$(PNP_IDS)"\" \
+ $(DISABLE_DEPRECATED_CFLAGS)
-lib_LTLIBRARIES = libmate-desktop-2.la
+AM_CFLAGS = $(WARN_CFLAGS)
noinst_PROGRAMS = test-ditem
@@ -47,11 +49,11 @@ test_ditem_LDADD = \
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = mate-desktop-2.0.pc
-pnpdata_DATA_dist = pnp.ids
if USE_INTERNAL_PNP_IDS
pnpdatadir = $(datadir)/libmate-desktop
pnpdata_DATA = pnp.ids
endif
+pnpdata_DATA_dist = pnp.ids
check:
test -s $(top_srcdir)/libmate-desktop/pnp.ids